projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8963207
)
uboot: fix ARCH for i386 and x86_64
author
Arnout Vandecappelle
<arnout@mind.be>
Sun, 15 Nov 2015 19:55:32 +0000
(20:55 +0100)
committer
Thomas Petazzoni
<thomas.petazzoni@free-electrons.com>
Mon, 16 Nov 2015 20:16:37 +0000
(21:16 +0100)
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/uboot/uboot.mk
patch
|
blob
|
history
diff --git
a/boot/uboot/uboot.mk
b/boot/uboot/uboot.mk
index 66e728f79db5dc7baa9ee7a41013ebab3099409b..0e3f808f7ebcf1c62adaa4d241c6158424b0762a 100644
(file)
--- a/
boot/uboot/uboot.mk
+++ b/
boot/uboot/uboot.mk
@@
-72,9
+72,11
@@
UBOOT_BIN_IFT = $(UBOOT_BIN).ift
endif
# The kernel calls AArch64 'arm64', but U-Boot calls it just 'arm', so
-# we have to special case it.
+# we have to special case it.
Similar for i386/x86_64 -> x86
ifeq ($(KERNEL_ARCH),arm64)
UBOOT_ARCH = arm
+else ifneq ($(filter $(KERNEL_ARCH),i386 x86_64),)
+UBOOT_ARCH = x86
else
UBOOT_ARCH = $(KERNEL_ARCH)
endif