package/sysrepo: use default CMAKE_BUILD_TYPE for host package
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Tue, 1 Jun 2021 14:34:10 +0000 (16:34 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 1 Jun 2021 20:39:33 +0000 (22:39 +0200)
Use the default build type for host-sysrepo.
In the current version of sysrepo, this happens to be 'Debug'.
As 'Debug' also enables tests, explicitly disable them.

Suggested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Acked-by: Heiko Thiery <heiko.thiery@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/sysrepo/sysrepo.mk

index dbc7b16b63fa572725b615648185359646deefb2..f5be29d2c9b60a1aa201052511537f119060acf9 100644 (file)
@@ -26,8 +26,9 @@ define SYSREPO_INSTALL_INIT_SYSV
 endef
 
 HOST_SYSREPO_CONF_OPTS = \
-       -DCMAKE_BUILD_TYPE=Release \
        -DBUILD_EXAMPLES=OFF \
+       -DENABLE_TESTS=OFF \
+       -DENABLE_VALGRIND_TESTS=OFF \
        -DREPO_PATH=$(TARGET_DIR)/etc/sysrepo
 
 $(eval $(cmake-package))