Terminate them with extreme prejudice.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+Signed-off-by: Adam Duskett <aduskett@gmail.com>
+[aduskett@gmail.com: Update for 7.2.2]
---
acinclude.m4 | 4 ----
1 file changed, 4 deletions(-)
index 28506b6..af4aa06 100644
--- a/acinclude.m4
+++ b/acinclude.m4
-@@ -1898,8 +1898,6 @@ define([phpshift],[ifelse(index([$@],[,]),-1,,[substr([$@],incr(index([$@],[,]))
+@@ -1890,8 +1890,6 @@ define([phpshift],[ifelse(index([$@],[,]),-1,,[substr([$@],incr(index([$@],[,]))
dnl
AC_DEFUN([PHP_CHECK_FUNC_LIB],[
ifelse($2,,:,[
unset found
AC_CHECK_LIB($2, $1, [found=yes], [
AC_CHECK_LIB($2, __$1, [found=yes], [found=no])
-@@ -1931,8 +1929,6 @@ dnl in the default libraries and as a fall back in the specified library.
+@@ -1923,8 +1921,6 @@ dnl in the default libraries and as a fall back in the specified library.
dnl Defines HAVE_func and HAVE_library if found and adds the library to LIBS.
dnl
AC_DEFUN([PHP_CHECK_FUNC],[
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
[Gustavo: convert to nice m4 instead of patching configure]
[Gustavo: update for 5.6.10]
+Signed-off-by: Adam Duskett <aduskett@gmail.com>
+[aduskett@gmail.com: Update for 7.2.2]
---
acinclude.m4 | 2 +-
ext/iconv/config.m4 | 22 ----------------------
index af4aa06..1bd2652 100644
--- a/acinclude.m4
+++ b/acinclude.m4
-@@ -2471,7 +2471,7 @@ AC_DEFUN([PHP_SETUP_ICONV], [
+@@ -2463,7 +2463,7 @@ AC_DEFUN([PHP_SETUP_ICONV], [
dnl
if test "$found_iconv" = "no"; then
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
[Gustavo: update for autoreconf/configure.in]
Signed-off-by: Adam Duskett <Adamduskett@outlook.com>
-[Aduskett: update for php7.2.1]
+[Aduskett: update for 7.2.2]
---
configure.ac | 9 ++-------
1 file changed, 2 insertions(+), 7 deletions(-)
index d20af76..7f02f1a 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -1419,13 +1419,8 @@ CFLAGS="\$(CFLAGS_CLEAN) $standard_libtool_flag"
+@@ -1420,13 +1420,8 @@ CFLAGS="\$(CFLAGS_CLEAN) $standard_libtool_flag"
INLINE_CFLAGS="$INLINE_CFLAGS $standard_libtool_flag"
CXXFLAGS="$CXXFLAGS $standard_libtool_flag \$(PROF_FLAGS)"
discovery
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+[aduskett@gmail.com: Update for 7.2.2]
+Signed-off-by: Adam Duskett <aduskett@gmail.com>
---
ext/fileinfo/config.m4 | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
index 7e98d62..8561962 100644
--- a/ext/fileinfo/config.m4
+++ b/ext/fileinfo/config.m4
-@@ -14,6 +14,7 @@ if test "$PHP_FILEINFO" != "no"; then
- libmagic/readcdf.c libmagic/softmagic.c"
+@@ -15,6 +15,7 @@ libmagic/readcdf.c libmagic/softmagic.c libmagic/der.c"
AC_MSG_CHECKING([for strcasestr])
+ AC_CACHE_VAL(ac_cv_func_strcasestr,
AC_TRY_RUN([
#include <string.h>
#include <strings.h>
+ #include <stdlib.h>
@@ -46,7 +47,7 @@ int main(void)
AC_MSG_RESULT(no)
AC_MSG_NOTICE(using libmagic strcasestr implementation)
--- /dev/null
+Avoid gcc segmentation fault
+
+Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
+Signed-off-by: Adam Duskett <aduskett@gmail.com>
+[aduskett@gmail.com: Update for 7.2.2]
+diff -Nur php-7.0.12.orig/Zend/zend_portability.h php-7.0.12/Zend/zend_portability.h
+--- php-7.0.12.orig/Zend/zend_portability.h 2016-10-13 16:04:17.000000000 +0200
++++ php-7.0.12/Zend/zend_portability.h 2016-11-08 02:49:39.118388999 +0100
+@@ -95,7 +95,7 @@
+
+ #if defined(ZEND_WIN32) && !defined(__clang__)
+ # define ZEND_ASSUME(c) __assume(c)
+-#elif ((defined(__GNUC__) && ZEND_GCC_VERSION >= 4005) || __has_builtin(__builtin_unreachable)) && PHP_HAVE_BUILTIN_EXPECT
++#elif ((defined(__GNUC__) && ZEND_GCC_VERSION >= 4005) || __has_builtin(__builtin_unreachable)) && PHP_HAVE_BUILTIN_EXPECT && !defined(__bfin__)
+ # define ZEND_ASSUME(c) do { \
+ if (__builtin_expect(!(c), 0)) __builtin_unreachable(); \
+ } while (0)
--- /dev/null
+From 4342bdea7a1a21430ce0d051fa4387441166c473 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fabrice.fontaine@orange.com>
+Date: Sun, 11 Dec 2016 23:12:46 +0100
+Subject: [PATCH] Call apxs with correct prefix
+
+php uses apache's apxs script from staging directory to install libphp
+dynamic library and update /etc/apache2/httpd.conf in the staging and target
+directories. Here is the full command line:
+"apxs -S LIBEXECDIR='$(INSTALL_ROOT)/usr/modules'
+ -S SYSCONFDIR='$(INSTALL_ROOT)/etc/apache2' -i -a -n php7"
+This does not work for target directory as apxs sets the full path of the
+library and not the relative one. Indeed, apxs is smart enough to substitute
+away the prefix specified in $(STAGING_DIR)/usr/build/config_vars.mk so
+httpd.conf will only be correct in the staging directory.
+To fix this, add -S PREFIX='$(INSTALL_ROOT)/usr' to apxs call in configure
+
+Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com>
+Signed-off-by: Adam Duskett <aduskett@gmail.com>
+[aduskett@gmail.com: Update for 7.2.2]
+---
+ sapi/apache2handler/config.m4 | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/sapi/apache2handler/config.m4 b/sapi/apache2handler/config.m4
+index 2e64b21..f5bf002 100644
+--- a/sapi/apache2handler/config.m4
++++ b/sapi/apache2handler/config.m4
+@@ -66,10 +66,12 @@ if test "$PHP_APXS2" != "no"; then
+ AC_MSG_ERROR([Please note that Apache version >= 2.0.44 is required])
+ fi
+
++ APXS_PREFIX='$(INSTALL_ROOT)'/usr
+ APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
+ if test -z `$APXS -q SYSCONFDIR`; then
+ INSTALL_IT="\$(mkinstalldirs) '$APXS_LIBEXECDIR' && \
+ $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
++ -S PREFIX='$APXS_PREFIX' \
+ -i -n php7"
+ else
+ APXS_SYSCONFDIR='$(INSTALL_ROOT)'`$APXS -q SYSCONFDIR`
+@@ -77,6 +79,7 @@ if test "$PHP_APXS2" != "no"; then
+ \$(mkinstalldirs) '$APXS_SYSCONFDIR' && \
+ $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
+ -S SYSCONFDIR='$APXS_SYSCONFDIR' \
++ -S PREFIX='$APXS_PREFIX' \
+ -i -a -n php7"
+ fi
+
+--
+2.5.0
+
+++ /dev/null
-Avoid gcc segmentation fault
-
-Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
-
-diff -Nur php-7.0.12.orig/Zend/zend_portability.h php-7.0.12/Zend/zend_portability.h
---- php-7.0.12.orig/Zend/zend_portability.h 2016-10-13 16:04:17.000000000 +0200
-+++ php-7.0.12/Zend/zend_portability.h 2016-11-08 02:49:39.118388999 +0100
-@@ -97,7 +97,7 @@
-
- #if defined(ZEND_WIN32) && !defined(__clang__)
- # define ZEND_ASSUME(c) __assume(c)
--#elif ((defined(__GNUC__) && ZEND_GCC_VERSION >= 4005) || __has_builtin(__builtin_unreachable)) && PHP_HAVE_BUILTIN_EXPECT
-+#elif ((defined(__GNUC__) && ZEND_GCC_VERSION >= 4005) || __has_builtin(__builtin_unreachable)) && PHP_HAVE_BUILTIN_EXPECT && !defined(__bfin__)
- # define ZEND_ASSUME(c) do { \
- if (__builtin_expect(!(c), 0)) __builtin_unreachable(); \
- } while (0)
+++ /dev/null
-From 4342bdea7a1a21430ce0d051fa4387441166c473 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fabrice.fontaine@orange.com>
-Date: Sun, 11 Dec 2016 23:12:46 +0100
-Subject: [PATCH] Call apxs with correct prefix
-
-php uses apache's apxs script from staging directory to install libphp
-dynamic library and update /etc/apache2/httpd.conf in the staging and target
-directories. Here is the full command line:
-"apxs -S LIBEXECDIR='$(INSTALL_ROOT)/usr/modules'
- -S SYSCONFDIR='$(INSTALL_ROOT)/etc/apache2' -i -a -n php7"
-This does not work for target directory as apxs sets the full path of the
-library and not the relative one. Indeed, apxs is smart enough to substitute
-away the prefix specified in $(STAGING_DIR)/usr/build/config_vars.mk so
-httpd.conf will only be correct in the staging directory.
-To fix this, add -S PREFIX='$(INSTALL_ROOT)/usr' to apxs call in configure
-
-Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com>
----
- sapi/apache2handler/config.m4 | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/sapi/apache2handler/config.m4 b/sapi/apache2handler/config.m4
-index 2e64b21..f5bf002 100644
---- a/sapi/apache2handler/config.m4
-+++ b/sapi/apache2handler/config.m4
-@@ -66,10 +66,12 @@ if test "$PHP_APXS2" != "no"; then
- AC_MSG_ERROR([Please note that Apache version >= 2.0.44 is required])
- fi
-
-+ APXS_PREFIX='$(INSTALL_ROOT)'/usr
- APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
- if test -z `$APXS -q SYSCONFDIR`; then
- INSTALL_IT="\$(mkinstalldirs) '$APXS_LIBEXECDIR' && \
- $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
-+ -S PREFIX='$APXS_PREFIX' \
- -i -n php7"
- else
- APXS_SYSCONFDIR='$(INSTALL_ROOT)'`$APXS -q SYSCONFDIR`
-@@ -77,6 +79,7 @@ if test "$PHP_APXS2" != "no"; then
- \$(mkinstalldirs) '$APXS_SYSCONFDIR' && \
- $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
- -S SYSCONFDIR='$APXS_SYSCONFDIR' \
-+ -S PREFIX='$APXS_PREFIX' \
- -i -a -n php7"
- fi
-
---
-2.5.0
-
# From http://php.net/downloads.php
-sha256 6c6cf82fda6660ed963821eb0525214bb3547e8e29f447b9c15b2d8e6efd8822 php-7.2.1.tar.xz
+sha256 47d7607d38a1d565fc43ea942c92229a7cd165f156737f210937e375b243cb11 php-7.2.2.tar.xz
# License file
-sha256 a44951f93b10c87c3f7cd9f311d95999c57c95ed950eec32b14c1c7ea6baf25e LICENSE
+sha256 00e567a8d50359d93ee1f9afdd9511277660c1e70a0cbf3229f84403aa9aebb1 LICENSE
#
################################################################################
-PHP_VERSION = 7.2.1
+PHP_VERSION = 7.2.2
PHP_SITE = http://www.php.net/distributions
PHP_SOURCE = php-$(PHP_VERSION).tar.xz
PHP_INSTALL_STAGING = YES