package/apache: enable optional support for nghttp2
authorRyan Coe <bluemrp9@gmail.com>
Sat, 29 Dec 2018 01:39:09 +0000 (17:39 -0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 30 Dec 2018 15:38:11 +0000 (16:38 +0100)
Signed-off-by: Ryan Coe <bluemrp9@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/apache/apache.mk

index 283c3cbd5047f832108e8ccdaf269f87ddfa8ad5..a95ac69f312738e71d9abcc0daecbfb4c0cf183f 100644 (file)
@@ -63,6 +63,15 @@ else
 APACHE_CONF_OPTS += --disable-lua
 endif
 
+ifeq ($(BR2_PACKAGE_NGHTTP2),y)
+APACHE_CONF_OPTS += \
+       --enable-http2 \
+       --with-nghttp2=$(STAGING_DIR)/usr
+APACHE_DEPENDENCIES += nghttp2
+else
+APACHE_CONF_OPTS += --disable-http2
+endif
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 APACHE_DEPENDENCIES += openssl
 APACHE_CONF_OPTS += \