Be sure things are built and installed just once
authorEric Andersen <andersen@codepoet.org>
Wed, 15 Jan 2003 10:41:02 +0000 (10:41 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 15 Jan 2003 10:41:02 +0000 (10:41 -0000)
make/automake.mk

index 722be38b206f03bb3cdef7f9a0756d81f6722180..52ffebb4a28c5302e8a1b5e34283a0d535ed4e6d 100644 (file)
@@ -30,6 +30,7 @@ $(AUTOMAKE_DIR)/.configured: $(AUTOMAKE_DIR)/.unpacked
 
 $(AUTOMAKE_DIR)/$(AUTOMAKE_BINARY): $(AUTOMAKE_DIR)/.configured
        $(MAKE) CC=$(TARGET_CC1) -C $(AUTOMAKE_DIR)
+       touch -c $(AUTOMAKE_DIR)/$(AUTOMAKE_BINARY)
 
 $(TARGET_DIR)/$(AUTOMAKE_TARGET_BINARY): $(AUTOMAKE_DIR)/$(AUTOMAKE_BINARY)
        PATH=$(STAGING_DIR)/bin:$$PATH CC=$(TARGET_CC1) \
@@ -48,6 +49,7 @@ $(TARGET_DIR)/$(AUTOMAKE_TARGET_BINARY): $(AUTOMAKE_DIR)/$(AUTOMAKE_BINARY)
            includedir=$(TARGET_DIR)/usr/include \
            -C $(AUTOMAKE_DIR) install;
        rm -rf $(TARGET_DIR)/share/locale
+       touch -c $(TARGET_DIR)/$(AUTOMAKE_TARGET_BINARY)
 
 automake: uclibc $(TARGET_DIR)/$(AUTOMAKE_TARGET_BINARY)