bzip2: install shared library for the host
authorDavid Bachelart <david.bachelart@bbright.com>
Thu, 10 Jul 2014 12:00:26 +0000 (14:00 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Jul 2014 18:28:05 +0000 (20:28 +0200)
libbz2.so was explicitly built for the host, but was not installed. Install it.

Signed-off-by: David Bachelart <david.bachelart@bbright.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/bzip2/bzip2.mk

index fcddb55e5f79ec4200d12b9fdbb900b92762ddd6..7584694802a0fc28ac97c1c08484518373baf46f 100644 (file)
@@ -61,6 +61,8 @@ endef
 define HOST_BZIP2_INSTALL_CMDS
        $(HOST_MAKE_ENV) \
                $(MAKE) PREFIX=$(HOST_DIR)/usr -C $(@D) install
+       $(HOST_MAKE_ENV) \
+               $(MAKE) -f Makefile-libbz2_so PREFIX=$(HOST_DIR)/usr -C $(@D) install
 endef
 
 $(eval $(generic-package))