ncurses: fix gpm support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 15 Dec 2014 22:00:11 +0000 (19:00 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 15 Dec 2014 22:32:20 +0000 (23:32 +0100)
The CF_LIB_SONAME macro doesn't work when cross compiling so we need to
specify the lib name for libgpm explicitly. While at it make gpm support
explicit in the form of --without-gpm when it's not selected and adding
it to dependencies when it is. Fixes:
http://autobuild.buildroot.net/results/32a/32a5ba3905772a3f2f2ec9d1b290a109fe22d9f9/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ncurses/ncurses.mk

index 7febed63f0c329e475459ecd6785400ecd283ab3..47378f70a6fbe704f1ed2a24c4f822bf8dacd692 100644 (file)
@@ -43,6 +43,14 @@ else ifeq ($(BR2_SHARED_STATIC_LIBS),y)
 NCURSES_CONF_OPTS += --with-shared --with-normal
 endif
 
+# configure can't find the soname for libgpm when cross compiling
+ifeq ($(BR2_PACKAGE_GPM),y)
+NCURSES_CONF_OPTS += --with-gpm=libgpm.so.2
+NCURSES_DEPENDENCIES += gpm
+else
+NCURSES_CONF_OPTS += --without-gpm
+endif
+
 NCURSES_LIBS-y = ncurses
 NCURSES_LIBS-$(BR2_PACKAGE_NCURSES_TARGET_MENU) += menu
 NCURSES_LIBS-$(BR2_PACKAGE_NCURSES_TARGET_PANEL) += panel