package/busybox: fix target-finalize hook
authorCarlos Santos <unixmania@gmail.com>
Wed, 25 Mar 2020 00:30:53 +0000 (21:30 -0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 25 Mar 2020 06:33:56 +0000 (07:33 +0100)
It was searching for CONFIG_ASH=y and CONFIG_HUSH=y at $(@D)/.config,
which does not contain the package build path at the target-finalize
step. Use $(BUSYBOX_DIR), instead.

Signed-off-by: Carlos Santos <unixmania@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/busybox/busybox.mk

index dfcd9d392c5937d3d9b89182babb1e3663df0f4f..b9d82ed71e034554018c0349828831a9c17c14fd 100644 (file)
@@ -318,11 +318,11 @@ endef
 # Add /bin/{a,hu}sh to /etc/shells otherwise some login tools like dropbear
 # can reject the user connection. See man shells.
 define BUSYBOX_INSTALL_ADD_TO_SHELLS
-       if grep -q CONFIG_ASH=y $(@D)/.config; then \
+       if grep -q CONFIG_ASH=y $(BUSYBOX_DIR)/.config; then \
                grep -qsE '^/bin/ash$$' $(TARGET_DIR)/etc/shells \
                || echo "/bin/ash" >> $(TARGET_DIR)/etc/shells; \
        fi
-       if grep -q CONFIG_HUSH=y $(@D)/.config; then \
+       if grep -q CONFIG_HUSH=y $(BUSYBOX_DIR)/.config; then \
                grep -qsE '^/bin/hush$$' $(TARGET_DIR)/etc/shells \
                || echo "/bin/hush" >> $(TARGET_DIR)/etc/shells; \
        fi