package/openipmi: fix musl build
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 31 Jan 2016 09:23:10 +0000 (10:23 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 7 Feb 2016 14:01:40 +0000 (15:01 +0100)
The build error is known upstream
http://sourceforge.net/p/openipmi/patches/26/
and was not yet caught by our autobuilders:

ui.c: In function ‘get_ip_addr’:
ui.c:340:5: error: unknown type name ‘u_int32_t’
     u_int32_t     addr;

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openipmi/openipmi.hash
package/openipmi/openipmi.mk

index 3a40f6068f606265b15d0a3f03d3ae14f805a3c4..e6fafe48ab07f1a8b599be229ddce43a74d11611 100644 (file)
@@ -1,2 +1,4 @@
 # From http://sourceforge.net/projects/openipmi/files/OpenIPMI%202.0%20Library/
 sha1 54f63ab7fe09f6a4b0b718601fe9c61014aa220b OpenIPMI-2.0.21.tar.gz
+# Locally computed
+sha256 0eafaa502ccf752899c5089159574081067d0c4ac53ea0ace33a5087f33ea32a        0001-ui-use-standard-uint32_t.patch
index 85bd6b406c2fe25a8366c884f938dd9d39c9f40a..4dd901b2bca7281da3c47253c2acf673cf71baa4 100644 (file)
@@ -7,6 +7,8 @@
 OPENIPMI_VERSION = 2.0.21
 OPENIPMI_SITE = http://sourceforge.net/projects/openipmi/files/OpenIPMI%202.0%20Library
 OPENIPMI_SOURCE = OpenIPMI-2.0.21.tar.gz
+OPENIPMI_PATCH = \
+       http://sourceforge.net/p/openipmi/patches/26/attachment/0001-ui-use-standard-uint32_t.patch
 OPENIPMI_LICENSE = LGPLv2+, GPLv2+, BSD-3c
 OPENIPMI_LICENSE_FILES = COPYING.LIB COPYING COPYING.BSD
 OPENIPMI_DEPENDENCIES = popt ncurses host-pkgconf