package/wine: bump to version 4.0
authorAndré Hentschel <nerv@dawncrow.de>
Sat, 9 Feb 2019 16:35:55 +0000 (17:35 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 11 Feb 2019 08:12:15 +0000 (09:12 +0100)
Signed-off-by: André Hentschel <nerv@dawncrow.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/wine/wine.hash
package/wine/wine.mk

index ba007142e86da108c1a6ac3e63d78624437b9f75..6993d6ecbc55f53481c99089056cc3127a29755d 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated after checking pgp signature
-sha256 d45a88edbe7db363e297cacedc94e66df3464504a01c2eccf04f518066a6fb0c wine-3.0.4.tar.xz
+sha256 6736cdee95b2b8bb021ec0c19497ed8cad5ae2c8bfdb7ab5dc687ff92a480d4d wine-4.0.tar.xz
index 7e44e3c81d16e66a62bab5c0d93711f9ff7fa9a8..78fa860ecf0bfa023ba5ddfded618c2c2f7efdc1 100644 (file)
@@ -4,9 +4,9 @@
 #
 ################################################################################
 
-WINE_VERSION = 3.0.4
+WINE_VERSION = 4.0
 WINE_SOURCE = wine-$(WINE_VERSION).tar.xz
-WINE_SITE = https://dl.winehq.org/wine/source/3.0
+WINE_SITE = https://dl.winehq.org/wine/source/4.0
 WINE_LICENSE = LGPL-2.1+
 WINE_LICENSE_FILES = COPYING.LIB LICENSE
 WINE_DEPENDENCIES = host-bison host-flex host-wine
@@ -25,7 +25,9 @@ WINE_CONF_OPTS = \
        --without-gsm \
        --without-hal \
        --without-opencl \
-       --without-oss
+       --without-oss \
+       --without-vkd3d \
+       --without-vulkan
 
 # Wine uses a wrapper around gcc, and uses the value of --host to
 # construct the filename of the gcc to call.  But for external
@@ -222,6 +224,13 @@ else
 WINE_CONF_OPTS += --without-sane
 endif
 
+ifeq ($(BR2_PACKAGE_SDL2),y)
+WINE_CONF_OPTS += --with-sdl
+WINE_DEPENDENCIES += sdl2
+else
+WINE_CONF_OPTS += --without-sdl
+endif
+
 ifeq ($(BR2_PACKAGE_TIFF),y)
 WINE_CONF_OPTS += --with-tiff
 WINE_DEPENDENCIES += tiff
@@ -356,6 +365,7 @@ HOST_WINE_CONF_OPTS += \
        --without-glu \
        --without-gnutls \
        --without-gsm \
+       --without-gssapi \
        --without-gstreamer \
        --without-hal \
        --without-jpeg \
@@ -372,8 +382,11 @@ HOST_WINE_CONF_OPTS += \
        --without-pulse \
        --without-png \
        --without-sane \
+       --without-sdl \
        --without-tiff \
        --without-v4l \
+       --without-vkd3d \
+       --without-vulkan \
        --without-x \
        --without-xcomposite \
        --without-xcursor \