package/mtd: needs zstd
authorJulien BOIBESSOT <julien.boibessot@armadeus.com>
Fri, 2 Aug 2019 12:21:09 +0000 (14:21 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Fri, 2 Aug 2019 15:10:50 +0000 (17:10 +0200)
For the target variant, zstd is an optional dependency when ubifs-tools
are enabled. For the host variant, we make it an unconditional
dependency.

Fixes:
http://autobuild.buildroot.org/results/99baf1de106f9c80a32e665263c1e4278097643d (target)
http://autobuild.buildroot.org/results/e3b96704f0b23e82999aa3d6e93233edecbecfe7 (host)

Signed-off-by: Julien BOIBESSOT <julien.boibessot@armadeus.com>
Tested-by: Markus Mayer <mmayer@broadcom.com>
[yann.morin.1998@free.fr: fix the target variant too]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/mtd/mtd.mk

index 0de14dbcba2a15822b74bcd3002acf36e398e805..3477460200e72becad66e33ba4266508d0629567 100644 (file)
@@ -27,6 +27,12 @@ MTD_CONF_OPTS += --with-crypto
 else
 MTD_CONF_OPTS += --without-crypto
 endif
+ifeq ($(BR2_PACKAGE_ZSTD),y)
+MTD_DEPENDENCIES += zstd
+MTD_CONF_OPTS += --with-zstd
+else
+MTD_CONF_OPTS += --without-zstd
+endif
 else
 MTD_CONF_OPTS += --without-ubifs
 endif
@@ -46,7 +52,7 @@ else
 MTD_CONF_OPTS += --without-xattr
 endif
 
-HOST_MTD_DEPENDENCIES = host-zlib host-lzo host-util-linux
+HOST_MTD_DEPENDENCIES = host-zlib host-lzo host-util-linux host-zstd
 HOST_MTD_CONF_OPTS = \
        --with-jffs \
        --with-ubifs \