webkitgtk: Allow building with BR2_PACKAGE_WEBKITGTK_MULTIMEDIA disabled
authorAdrián Pérez de Castro <aperez@igalia.com>
Sat, 29 Jul 2017 13:18:44 +0000 (16:18 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Jul 2017 13:34:35 +0000 (15:34 +0200)
Explicitly pass "-DENABLE_MEDIA_STREAM=OFF" to CMake, to workaround a
missing feature dependency in the WebKitGTK+ build files.

Related upstream bug: https://bugs.webkit.org/show_bug.cgi?id=174940

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/webkitgtk/webkitgtk.mk

index b200d23262e29db4bd13700874f455e0405c9eb8..e30d07fc1d79f256886028f676fafe566ae5bdc0 100644 (file)
@@ -40,9 +40,13 @@ WEBKITGTK_CONF_OPTS += \
        -DENABLE_WEB_AUDIO=ON
 WEBKITGTK_DEPENDENCIES += gstreamer1 gst1-libav gst1-plugins-base gst1-plugins-good
 else
+# ENABLE_MEDIA_STREAM has to be explicitly disabled because there is a missing
+# feature dependency in the WebKitGTK+ CMake files. This can be removed once
+# https://bugs.webkit.org/show_bug.cgi?id=174940 makes it into a release.
 WEBKITGTK_CONF_OPTS += \
        -DENABLE_VIDEO=OFF \
-       -DENABLE_WEB_AUDIO=OFF
+       -DENABLE_WEB_AUDIO=OFF \
+       -DENABLE_MEDIA_STREAM=OFF
 endif
 
 # Only one target platform can be built, assume X11 > Wayland