libuecc: new package
authorAlexander Dahl <post@lespocky.de>
Thu, 29 Oct 2015 07:13:01 +0000 (08:13 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 4 Nov 2015 20:42:30 +0000 (21:42 +0100)
This package is a small library used for the Freifunk Gluon project
and will be used by other upcoming packages.

Signed-off-by: Alexander Dahl <post@lespocky.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libuecc/Config.in [new file with mode: 0644]
package/libuecc/libuecc.mk [new file with mode: 0644]

index 3a0bd2fb47a66ac7e80142d4ddb55c9f0531041a..98411b33b66a60410b5b4a9379b7776b9e998cda 100644 (file)
@@ -764,6 +764,7 @@ menu "Crypto"
        source "package/libsodium/Config.in"
        source "package/libssh/Config.in"
        source "package/libssh2/Config.in"
+       source "package/libuecc/Config.in"
        source "package/nettle/Config.in"
        source "package/openssl/Config.in"
        source "package/polarssl/Config.in"
diff --git a/package/libuecc/Config.in b/package/libuecc/Config.in
new file mode 100644 (file)
index 0000000..34bbea2
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LIBUECC
+       bool "libuecc"
+       help
+         Very small Elliptic Curve Cryptography library
+
+         http://git.universe-factory.net/libuecc
diff --git a/package/libuecc/libuecc.mk b/package/libuecc/libuecc.mk
new file mode 100644 (file)
index 0000000..bddb7d5
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# libuecc
+#
+################################################################################
+
+LIBUECC_VERSION = v6
+LIBUECC_SITE = git://git.universe-factory.net/libuecc
+LIBUECC_LICENSE = BSD-2c
+LIBUECC_LICENSE_FILES = COPYRIGHT
+LIBUECC_INSTALL_STAGING = YES
+
+$(eval $(cmake-package))