toolchain-external: remove support for 'Sourcery CodeBench ARM 2011.03'
authorFabio Porcedda <fabio.porcedda@gmail.com>
Sun, 26 May 2013 12:08:20 +0000 (12:08 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 27 May 2013 22:00:30 +0000 (00:00 +0200)
Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index 5fdd27b7a79980e785b0e7bcaf59f777ddf0ded2..515c08674829726ce9bae3f9d61a568968e02ecf 100644 (file)
@@ -276,30 +276,6 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201203
            - MIPS32 little endian soft float uclibc
              Not usable in Buildroot yet.
 
-config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201103
-       bool "Sourcery CodeBench ARM 2011.03"
-       depends on BR2_arm
-       depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
-       select BR2_TOOLCHAIN_EXTERNAL_GLIBC
-       select BR2_TOOLCHAIN_HAS_NATIVE_RPC
-       select BR2_INSTALL_LIBSTDCPP
-       select BR2_HOSTARCH_NEEDS_IA32_LIBS
-       help
-         Sourcery CodeBench toolchain for the ARM architecture, from
-         Mentor Graphics. It uses gcc 4.5.2, binutils 2.20.51, glibc
-         2.13 and gdb 7.2.50, kernel headers 2.6.38. It has support
-         for the following variants:
-           - ARMv5TE, little endian, soft-float, glibc
-             Select ARM926T, ARM10T, XScale or another ARMv5 core
-             Select BR2_SOFT_FLOAT
-           - ARMv4T, little endian, soft-float, glibc
-             Select ARM720T, ARM920T, ARM922T or another ARMv4 core
-             Select BR2_SOFT_FLOAT
-           - ARMv7-A, Thumb 2, little endian, soft-float, glibc
-             Select Cortex-A8, Cortex-A9 or another ARMv7-A core
-             Select BR2_SOFT_FLOAT
-             Set BR2_TARGET_OPTIMIZATION to -mthumb
-
 config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201109
        bool "Sourcery CodeBench MIPS 2011.09"
        depends on BR2_mips || BR2_mipsel
@@ -785,7 +761,6 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_03
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_02
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2013_01
-       default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201103
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201305
index b6532fcf56ed210b5f6d23219b798cd60132e0a8..b18f9adb57d8a135951f6fdff27f1fda2ace9cf3 100644 (file)
@@ -191,10 +191,7 @@ ifeq ($(BR2_TOOLCHAIN_EXTERNAL_DOWNLOAD),y)
 TOOLCHAIN_EXTERNAL_DEPENDENCIES = $(TOOLCHAIN_EXTERNAL_DIR)/.extracted
 endif
 
-ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201103),y)
-TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/public/gnu_toolchain/arm-none-linux-gnueabi/
-TOOLCHAIN_EXTERNAL_SOURCE=arm-2011.03-41-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109),y)
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/public/gnu_toolchain/arm-none-linux-gnueabi/
 TOOLCHAIN_EXTERNAL_SOURCE=arm-2011.09-70-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203),y)