bluez5_utils: allow enabling formerly experimental plugins
authorAndy Shevchenko <andriy.shevchenko@linux.intel.com>
Mon, 1 May 2017 12:59:43 +0000 (15:59 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 5 May 2017 12:36:29 +0000 (14:36 +0200)
Disregard to increase just minor version BlueZ 5.44 is drastically different in
a way what plugins that used to be enabled by the --enable-experimental
configure option, now have their own option.

Extend Buildroot package to cover these plugins.

Cc: Marcin Bis <marcin@bis.org.pl>
Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/bluez5_utils/Config.in
package/bluez5_utils/bluez5_utils.mk

index f8e3540ec5e9b99940370b3ea946d5a2ffb1092c..181003b42c9b16842785240e7a5394343fe31813 100644 (file)
@@ -61,6 +61,21 @@ config BR2_PACKAGE_BLUEZ5_UTILS_EXPERIMENTAL
        help
          Build BlueZ 5.x experimental Nokia OBEX PC Suite plugin
 
+config BR2_PACKAGE_BLUEZ5_PLUGINS_HEALTH
+       bool "build health plugin"
+       help
+         Build BlueZ 5.x health plugin
+
+config BR2_PACKAGE_BLUEZ5_PLUGINS_NFC
+       bool "build nfc plugin"
+       help
+         Build BlueZ 5.x nfc plugin
+
+config BR2_PACKAGE_BLUEZ5_PLUGINS_SAP
+       bool "build sap plugin"
+       help
+         Build BlueZ 5.x sap plugin
+
 config BR2_PACKAGE_BLUEZ5_PLUGINS_SIXAXIS
        bool "build sixaxis plugin"
        depends on BR2_PACKAGE_HAS_UDEV
index fac79580024fdc435ca5f8ef8143255470f7e704..431783997d7f4ba59f445c0e12f4d3b50da004ce 100644 (file)
@@ -38,6 +38,27 @@ else
 BLUEZ5_UTILS_CONF_OPTS += --disable-experimental
 endif
 
+# enable health plugin
+ifeq ($(BR2_PACKAGE_BLUEZ5_PLUGINS_HEALTH),y)
+BLUEZ5_UTILS_CONF_OPTS += --enable-health
+else
+BLUEZ5_UTILS_CONF_OPTS += --disable-health
+endif
+
+# enable nfc plugin
+ifeq ($(BR2_PACKAGE_BLUEZ5_PLUGINS_NFC),y)
+BLUEZ5_UTILS_CONF_OPTS += --enable-nfc
+else
+BLUEZ5_UTILS_CONF_OPTS += --disable-nfc
+endif
+
+# enable sap plugin
+ifeq ($(BR2_PACKAGE_BLUEZ5_PLUGINS_SAP),y)
+BLUEZ5_UTILS_CONF_OPTS += --enable-sap
+else
+BLUEZ5_UTILS_CONF_OPTS += --disable-sap
+endif
+
 # enable sixaxis plugin
 ifeq ($(BR2_PACKAGE_BLUEZ5_PLUGINS_SIXAXIS),y)
 BLUEZ5_UTILS_CONF_OPTS += --enable-sixaxis