sispmctl: new package
authorPhil Eichinger <phil.eichinger@gmail.com>
Thu, 29 May 2014 15:05:33 +0000 (17:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 9 Jun 2014 12:38:38 +0000 (14:38 +0200)
[Thomas:
 - Add missing select of BR2_PACKAGE_LIBUSB, since
   BR2_PACKAGE_LIBUSB_COMPAT depends on it
 - Add missing thread dependency, since libusb requires threads.
 - Add missing wide-char dependency. Without wide char support,
   sispmctl doesn't build.
 - Rewrap the Config.in help text, and remove trailing whitespaces.
 - License is GPLv2+, not GPLv2.
 - Remove --disable-dependency-tracking from <pkg>_CONF_OPT. That's a
   global, standard, autoconf option, and there's no reason to pass it
   at the per-package level.]

Signed-off-by: Phil Eichinger <phil@zankapfel.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/sispmctl/Config.in [new file with mode: 0644]
package/sispmctl/sispmctl.mk [new file with mode: 0644]

index 0440ce8011f3b2bc4abcab1d999cadfc8417cbd6..e234054a0fbadefee44247e34c5685661bd0cd15 100644 (file)
@@ -343,6 +343,7 @@ source "package/sane-backends/Config.in"
 source "package/sdparm/Config.in"
 source "package/setserial/Config.in"
 source "package/sg3_utils/Config.in"
+source "package/sispmctl/Config.in"
 source "package/smartmontools/Config.in"
 source "package/smstools3/Config.in"
 source "package/snowball-hdmiservice/Config.in"
diff --git a/package/sispmctl/Config.in b/package/sispmctl/Config.in
new file mode 100644 (file)
index 0000000..8070802
--- /dev/null
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_SISPMCTL
+       bool "sispmctl"
+       select BR2_PACKAGE_LIBUSB
+       select BR2_PACKAGE_LIBUSB_COMPAT
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
+       depends on BR2_USE_WCHAR
+       depends on BR2_USE_MMU # fork()
+       help
+         sispmctl is an application enabling the use of the GEMBIRD
+         SiS-PM and mSiS(sispm) USB-controlled power-outlet device
+         under Linux.  Note that the device is also sold under
+         different Names, i.e. as "IntelliPlug" in Germany.
+
+         http://sispmctl.sourceforge.net/
+
+comment "sispmctl needs a toolchain w/ threads, wchar"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
diff --git a/package/sispmctl/sispmctl.mk b/package/sispmctl/sispmctl.mk
new file mode 100644 (file)
index 0000000..2d2becf
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# sispmctl
+#
+################################################################################
+
+SISPMCTL_VERSION = 3.1
+SISPMCTL_SITE = http://downloads.sourceforge.net/project/sispmctl/sispmctl/sispmctl-$(SISPMCTL_VERSION)
+SISPMCTL_LICENSE = GPLv2+
+SISPMCTL_LICENSE_FILES = LICENCE
+SISPMCTL_DEPENDENCIES = libusb-compat
+
+SISPMCTL_CONF_ENV = HAVELIBUSB=$(STAGING_DIR)/usr/bin/libusb-config
+SISPMCTL_CONF_OPT = --enable-webless
+
+$(eval $(autotools-package))