package/netsurf: make sure host libpng can be found
authorFrancois Perrad <fperrad@gmail.com>
Thu, 13 Dec 2018 18:54:33 +0000 (19:54 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 17 Dec 2018 08:19:42 +0000 (09:19 +0100)
Commit 42c8f9f6b46e196a7c337c683a7df5ae6bd421b2 ("package/netsurf: add
dependency on host-libpng for sdl") ensured host-libpng was built
prior to netsurf when the SDL backend is selected. However, this is
not sufficient for the netsurf build system to find libpng on the
host, we need to help by providing the right HOST_CFLAGS and
HOST_LDFLAGS.

Fixes:

  http://autobuild.buildroot.net/results/d0bbd563fe5c9463316b2ba0d7ef5553be0563bc/

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
[Thomas: rewrite commit message.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/netsurf/netsurf.mk

index 692d2b770cb81055d0401b6828349941d8593b08..e5a251b9c122424cd2b2f46ee372250be5631280 100644 (file)
@@ -35,6 +35,9 @@ endif
 ifeq ($(BR2_PACKAGE_NETSURF_SDL),y)
 NETSURF_DEPENDENCIES += sdl host-libpng
 NETSURF_FRONTEND = framebuffer
+NETSURF_CONFIG = \
+       HOST_CFLAGS=-I$(HOST_DIR)/include \
+       HOST_LDFLAGS='-lpng -L$(HOST_DIR)/lib'
 ifeq ($(BR2_PACKAGE_FREETYPE),y)
 NETSURF_DEPENDENCIES += freetype
 define NETSURF_FONTLIB_CONFIGURE_CMDS
@@ -76,6 +79,7 @@ NETSURF_MAKE_OPTS = \
        CC="$(TARGET_CC)" \
        AR="$(TARGET_AR)" \
        TMP_PREFIX=$(STAGING_DIR)/usr \
+       NETSURF_CONFIG="$(NETSURF_CONFIG)" \
        PREFIX=/usr
 
 define NETSURF_BUILD_CMDS