package/libftdi: add license
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 24 Nov 2019 10:08:46 +0000 (11:08 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 24 Nov 2019 13:29:18 +0000 (14:29 +0100)
The COPYING.LIB license file contains the test of the LGPL-2.0, but the
source code itself explicitly refers to the GPL-2.1-only. Additionally,
parts of the library (src/ftdi_stream.c) are under the MIT license.

The C++ bindings are udner the GPL-2.0-only with an exception, which is
expressed in the LICENSE file.

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr:
  - the library is under both GPL-2.1-only and MIT
  - the GPL-2.0-only only applies to the C++ bindings
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libftdi/libftdi.hash
package/libftdi/libftdi.mk

index 5d9f8765db7528ca48f07c7c070b9455c440c9e1..8271ab277a14f3ef4adfbe3ce90470270f09c08f 100644 (file)
@@ -1,2 +1,7 @@
 # Locally computed (after checking the signature from http://www.intra2net.com/en/developer/libftdi/download.php)
 sha256  3176d5b5986438f33f5208e690a8bfe90941be501cc0a72118ce3d338d4b838e  libftdi-0.20.tar.gz
+
+# Hash for license files:
+sha256  6bd354f4b9beca001b1b5395be48cef1d749a3ed27dddb8114bf09eb0ab2d88c  LICENSE
+sha256  ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6  COPYING.GPL
+sha256  c340cbee4974bb96019e782f2279df016c92fb1e7f5299347e779d9acedbb991  COPYING.LIB
index cdd77c2e68ece4ae9ccd36db598f5833266f3f47..f5d557183fe54a02bd0ddb4fae14c6c40360422d 100644 (file)
@@ -6,6 +6,8 @@
 
 LIBFTDI_VERSION = 0.20
 LIBFTDI_SITE = http://www.intra2net.com/en/developer/libftdi/download
+LIBFTDI_LICENSE = LGPL-2.1 (libftdi), MIT (libftdi)
+LIBFTDI_LICENSE_FILES = LICENSE COPYING.LIB
 LIBFTDI_DEPENDENCIES = libusb-compat libusb
 HOST_LIBFTDI_DEPENDENCIES = host-libusb-compat host-libusb
 LIBFTDI_INSTALL_STAGING = YES
@@ -16,6 +18,8 @@ LIBFTDI_CONF_OPTS = --without-examples
 
 # configure detect it automaticaly so we need to force it
 ifeq ($(BR2_PACKAGE_LIBFTDI_CPP),y)
+LIBFTDI_LICENSE += , GPL-2.0 with exception (ftdipp)
+LIBFTDI_LICENSE_FILES = COPYING.GPL
 LIBFTDI_DEPENDENCIES += boost
 LIBFTDI_CONF_OPTS += --enable-libftdipp
 else