lxc: revive "drop-werror" patch
authorJérôme Pouiller <jezz@sysmic.org>
Sat, 3 Sep 2016 15:24:49 +0000 (17:24 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 3 Sep 2016 18:42:53 +0000 (20:42 +0200)
commit 5050a94ae9f448641e05ce29c931671ffdc62784 dropped patch that
remove '-Werror' from CFLAGS. However, it seems this patch is still
necessary:

  http://autobuild.buildroot.net/results/b1cbca6d0396863654b1d09ccc3163c5f6124ab8
  http://autobuild.buildroot.net/results/fcf2834ad74b95548d25dad2274704ea401f9665
  http://autobuild.buildroot.net/results/048be2fc702c9dba9ca4439ff687d71b30c10551
  http://autobuild.buildroot.net/results/939246c9a4f433dfd0dc414988f5957441b8e9b4

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lxc/0001-drop-werror.patch [new file with mode: 0644]
package/lxc/lxc.mk

diff --git a/package/lxc/0001-drop-werror.patch b/package/lxc/0001-drop-werror.patch
new file mode 100644 (file)
index 0000000..d2a8673
--- /dev/null
@@ -0,0 +1,16 @@
+Don't do -Werror it breaks builds on some scenarios with trivialities.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura lxc-lxc-1.0.4/configure.ac lxc-lxc-1.0.4.orig/configure.ac
+--- lxc-lxc-1.0.4.orig/configure.ac    2014-07-04 10:31:19.821029891 -0300
++++ lxc-lxc-1.0.4/configure.ac 2014-06-13 14:07:45.000000000 -0300
+@@ -560,7 +560,7 @@
+ LXC_CHECK_TLS
+ if test "x$GCC" = "xyes"; then
+-      CFLAGS="$CFLAGS -Wall -Werror"
++      CFLAGS="$CFLAGS -Wall"
+ fi
+ # Files requiring some variable expansion
index b1cd3858786428371802a78e49883871f2ec02eb..a3e24b4367d02a93325ac907fb7f6f20ce715bb5 100644 (file)
@@ -9,6 +9,8 @@ LXC_SITE = https://linuxcontainers.org/downloads/lxc
 LXC_LICENSE = LGPLv2.1+
 LXC_LICENSE_FILES = COPYING
 LXC_DEPENDENCIES = libcap host-pkgconf
+# we're patching configure.ac
+LXC_AUTORECONF = YES
 LXC_CONF_OPTS = --disable-apparmor --with-distro=buildroot \
        --disable-lua --disable-python \
        $(if $(BR2_PACKAGE_BASH),,--disable-bash)