package/pkg-rebar.mk: change semantic of <PKG>_KEEP_DEPENDENCIES
authorJohan Oudinet <johan.oudinet@gmail.com>
Wed, 5 Dec 2018 16:06:17 +0000 (17:06 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 9 Dec 2018 16:24:17 +0000 (17:24 +0100)
Set it to NO by default and check if it is equal to NO. This is to
be more consistent with other boolean variables in Buildroot.

Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-rebar.mk

index 838e7681deac07007eefaf1e27cd10dd51eea3f2..e4e3f3bb6c91385b66d8d23f41e69b624c450feb 100644 (file)
@@ -234,9 +234,11 @@ $(2)_REBAR = rebar
 $(2)_DEPENDENCIES += host-erlang-rebar
 endif
 
+$(2)_KEEP_DEPENDENCIES ?= NO
+
 # Remove dependencies listed in rebar.config unless the package says
 # otherwise
-ifeq ($$($(2)_KEEP_DEPENDENCIES),)
+ifeq ($$($(2)_KEEP_DEPENDENCIES),NO)
 $(2)_POST_PATCH_HOOKS += remove-rebar-config-dependencies
 endif