pcre: fix compilation when C++ support is disabled
authorPeter Korsgaard <jacmet@sunsite.dk>
Sat, 16 Aug 2008 12:32:54 +0000 (12:32 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 16 Aug 2008 12:32:54 +0000 (12:32 -0000)
pcre will use host g++ is no cross g++ is available, so explicitly disable
c++ support in pcre if it isn't enabled in buildroot instead.

package/pcre/pcre.mk

index f6f7003d0ac03d2ac99cfc548671fcaada104469..367f36cf1166d34f894c803bc9535ae3ab0fe272 100644 (file)
@@ -9,9 +9,10 @@ PCRE_SITE = ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre
 PCRE_INSTALL_STAGING = YES
 PCRE_INSTALL_TARGET = YES
 
-PCRE_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
-        --build=$(GNU_HOST_NAME) --prefix=/usr \
-        --includedir=/usr/include
+ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
+# pcre will use the host g++ if a cross version isn't available
+PCRE_CONF_OPT = --disable-cpp
+endif
 
 PCRE_DEPENDENCIES = uclibc