wvstreams: disable warnings
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 9 May 2013 02:28:38 +0000 (02:28 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 11 May 2013 07:36:46 +0000 (09:36 +0200)
During the compilation of wvstreams, a number of strict aliasing
related warnings are shown, making the build quite noisy. Turn
warnings off using the --disable-warnings option.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/wvstreams/wvstreams.mk

index 341fc095b400ded1c5faa78ce22ee89a32a4e0ca..837c4495b3495a14c8b65d1d31d16d759f465402 100644 (file)
@@ -18,7 +18,11 @@ WVSTREAMS_MAKE = $(MAKE1)
 # Needed to work around problem with wvassert.h
 WVSTREAMS_CONF_OPT += CPPFLAGS=-DNDEBUG
 
-WVSTREAMS_CONF_OPT += --with-openssl --with-zlib --without-pam
+WVSTREAMS_CONF_OPT += \
+       --with-openssl \
+       --with-zlib \
+       --without-pam \
+       --disable-warnings
 
 ifeq ($(BR2_PACKAGE_DBUS),y)
        WVSTREAMS_DEPENDENCIES += dbus