toolchain-external: remove Sourcery CodeBench ARM 2010q1
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Nov 2012 07:34:23 +0000 (07:34 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 6 Nov 2012 07:20:19 +0000 (08:20 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index 882c04af1a7b83dbc58ebae51e66b9e91065d92b..68b68ffe3bbe967dd949ddf6e7fe95f47ba2a815 100644 (file)
@@ -176,28 +176,6 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201009
              Select BR2_SOFT_FLOAT
              Set BR2_TARGET_OPTIMIZATION to -mthumb
 
-config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2010Q1
-       bool "Sourcery CodeBench ARM 2010q1"
-       depends on BR2_arm
-       select BR2_TOOLCHAIN_EXTERNAL_GLIBC
-       select BR2_TOOLCHAIN_HAS_NATIVE_RPC
-       select BR2_INSTALL_LIBSTDCPP
-       help
-         Sourcery CodeBench toolchain for the ARM architecture, from
-         Mentor Graphics. It uses gcc 4.4.1, binutils 2.19, glibc
-         2.11, gdb 7.0.50 and kernel headers 2.6.32. It has support
-         for the following variants:
-            - ARMv5T, little endian, soft-float, glibc
-              Select ARM926T, ARM10T, XScale or another ARMv5 core
-              Select BR2_SOFT_FLOAT
-            - ARMv4T, little endian, soft-float, glibc
-              Select ARM720T, ARM920T, ARM922T or another ARMv4 core
-              Select BR2_SOFT_FLOAT
-            - ARMv7-A, Thumb 2, little endian, soft-float, glibc
-              Select Cortex-A8, Cortex-A9 or another ARMv7-A core
-              Select BR2_SOFT_FLOAT
-              Set BR2_TARGET_OPTIMIZATION to -mthumb
-
 config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201109
        bool "Sourcery CodeBench MIPS 2011.09"
        depends on BR2_mips || BR2_mipsel
@@ -749,7 +727,6 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_08
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10
-       default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2010Q1
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201009
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201103
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109
index 429ff86ce75609e46f47007a81ff5b05ce1a4899..292f6987cc62b6291e9966f4daeab9a21e0a1a71 100644 (file)
@@ -175,10 +175,7 @@ ifeq ($(BR2_TOOLCHAIN_EXTERNAL_DOWNLOAD),y)
 TOOLCHAIN_EXTERNAL_DEPENDENCIES = $(TOOLCHAIN_EXTERNAL_DIR)/.extracted
 endif
 
-ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2010Q1),y)
-TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/arm/portal/package6488/public/arm-none-linux-gnueabi/
-TOOLCHAIN_EXTERNAL_SOURCE=arm-2010q1-202-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201009),y)
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201009),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/arm/portal/package7851/public/arm-none-linux-gnueabi/
 TOOLCHAIN_EXTERNAL_SOURCE=arm-2010.09-50-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201103),y)