olsr: bump to version 0.6.4
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 29 Jan 2013 11:20:04 +0000 (11:20 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 29 Jan 2013 21:46:43 +0000 (22:46 +0100)
Bump olsrd to version 0.6.4

Fixes:
http://autobuild.buildroot.net/results/553c8157cd83ca60475caacc119779c778806781/
which is due to the old version not being friendly with newer flex
versions.

Enabled more plugins to make it more useful.

Switch to forked mode in the init script to avoid console noise.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/olsr/Config.in
package/olsr/S50olsr
package/olsr/olsr-configurable-ldconfig.patch
package/olsr/olsr.mk

index ada82b406606a09d0cdcd16d7343e66290a34c97..a4fbe010403be4ce5e91f13195497157685c0918 100644 (file)
@@ -1,6 +1,8 @@
 config BR2_PACKAGE_OLSR
        bool "OLSR mesh networking Daemon"
+       depends on BR2_USE_MMU # fork()
        depends on BR2_INET_IPV6
+       depends on BR2_TOOLCHAIN_HAS_THREADS
        help
          The Optimized Link State Routing protocol (OLSR) is a
          routing protocol that is optimised for mobile ad-hoc
@@ -11,5 +13,5 @@ config BR2_PACKAGE_OLSR
 
          http://www.olsr.org/
 
-comment "olsr requires a toolchain with IPv6 support"
-       depends on !BR2_INET_IPV6
+comment "olsr requires a toolchain with IPv6 and threads support"
+       depends on !BR2_INET_IPV6 || !BR2_TOOLCHAIN_HAS_THREADS
index a8aefd37450142bf6ad7fc3490eb3386949f491c..9f052da53ef4e9687e189e0578648d90ecad3457 100755 (executable)
@@ -6,7 +6,7 @@
 case "$1" in
   start)
        echo "Starting OLSRd daemon: "
-       /usr/sbin/olsrd -d 0 -nofork & 
+       /usr/sbin/olsrd -d 0
        ;;
   stop)
        echo "Stopping OLSRd daemon: "
index 09e34f137a9f6399d3d1f6ae2d5faf7c31beb4a8..73fff7eecfccdf22f87dfb639fdfa2a2ae4ef329 100644 (file)
@@ -5,25 +5,28 @@ we make the path to ldconfig configurable through the environment/make
 command line. This allows to pass LDCONFIG=/bin/true when doing
 cross-compilation.
 
+[Gustavo: update patch for olsr 0.6.4]
 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
 
-Index: b/make/Makefile.linux
-===================================================================
---- a/make/Makefile.linux
-+++ b/make/Makefile.linux
+diff -Nura olsrd-0.6.4.orig/make/Makefile.linux olsrd-0.6.4/make/Makefile.linux
+--- olsrd-0.6.4.orig/make/Makefile.linux       2013-01-29 09:00:18.041356389 -0300
++++ olsrd-0.6.4/make/Makefile.linux    2013-01-29 09:01:51.598226624 -0300
 @@ -3,6 +3,7 @@
  #
  
  ARCH := $(shell uname -m)
 +LDCONFIG ?= /sbin/ldconfig
- DESTDIR ?=
- LIBDIR =      $(DESTDIR)$(shell if [ "$(ARCH)" = "x86_64" -a -d "/usr/lib64" ]; then echo "/usr/lib64"; else echo "/usr/lib"; fi)
-@@ -14,7 +15,7 @@
  
+ DESTDIR ?=
+ prefix ?= /usr/local
+@@ -26,9 +27,9 @@
+ PLUGIN_SONAME ?= lib$(PLUGIN_NAME).so
  PLUGIN_FULLNAME ?= $(PLUGIN_NAME).so.$(PLUGIN_VER)
  INSTALL_LIB = install -D -m 755 $(PLUGIN_FULLNAME) $(LIBDIR)/$(PLUGIN_FULLNAME); \
 -              /sbin/ldconfig -n $(LIBDIR)
++              $(LDCONFIG) -n $(LIBDIR)
+ UNINSTALL_LIB =       rm -f $(LIBDIR)/$(PLUGIN_FULLNAME); \
+-              /sbin/ldconfig -n $(LIBDIR)
 +              $(LDCONFIG) -n $(LIBDIR)
  
  ifdef OLSRD_PLUGIN
index be1ae1e4b463b0833769ef1c8905f50b6bd80524..97088f33b3c754c04cbfddbd2cb27b16a8b33661 100644 (file)
@@ -4,13 +4,17 @@
 #
 #############################################################
 
-OLSR_VERSION_MAJOR = 0.5
-OLSR_VERSION_MINOR = 6
+OLSR_VERSION_MAJOR = 0.6
+OLSR_VERSION_MINOR = 4
 OLSR_VERSION = $(OLSR_VERSION_MAJOR).$(OLSR_VERSION_MINOR)
 OLSR_SOURCE = olsrd-$(OLSR_VERSION).tar.bz2
 OLSR_SITE = http://www.olsr.org/releases/$(OLSR_VERSION_MAJOR)
-#OLSR_PLUGINS=httpinfo tas dot_draw nameservice dyn_gw dyn_gw_plain pgraph bmf quagga secure
-OLSR_PLUGINS = dot_draw dyn_gw secure
+OLSR_PLUGINS = arprefresh bmf dot_draw dyn_gw dyn_gw_plain httpinfo jsoninfo \
+       mdns nameservice p2pd pgraph secure txtinfo watchdog
+# Doesn't really need quagga but not very useful without it
+OLSR_PLUGINS += $(if $(BR2_PACKAGE_QUAGGA),quagga)
+OLSR_LICENSE = BSD-3c LGPLv2.1+
+OLSR_LICENSE_FILES = license.txt lib/pud/nmealib/LICENSE
 
 define OLSR_BUILD_CMDS
        $(TARGET_CONFIGURE_OPTS) $(MAKE) ARCH=$(KERNEL_ARCH) -C $(@D) olsrd
@@ -20,10 +24,12 @@ define OLSR_BUILD_CMDS
 endef
 
 define OLSR_INSTALL_TARGET_CMDS
-       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install_bin
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) \
+               prefix="/usr" install_bin
        for p in $(OLSR_PLUGINS) ; do \
                $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)/lib/$$p \
-                       LDCONFIG=/bin/true DESTDIR=$(TARGET_DIR) install ; \
+                       LDCONFIG=/bin/true DESTDIR=$(TARGET_DIR) \
+                       prefix="/usr" install ; \
        done
        $(INSTALL) -D -m 0755 package/olsr/S50olsr $(TARGET_DIR)/etc/init.d/S50olsr
        test -r $(TARGET_DIR)/etc/olsrd.conf || \