package/gvfs: fix static build with libarchive
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 27 Oct 2019 07:33:17 +0000 (08:33 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 27 Oct 2019 08:51:17 +0000 (09:51 +0100)
Use pkg-config to retrieve static dependencies of libarchive in gvfs.mk
instead of patching configure.ac as upstream switched to meson

Fixes:
 - http://autobuild.buildroot.org/results/486187bb7b8800f44a8c173af518b84e68e53584

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gvfs/gvfs.mk

index 9bfe9e60fbc72a5a94f3339ed01d590b8344b736..c380a710fb030af1ca4818c7c39725572f53a477 100644 (file)
@@ -13,12 +13,13 @@ GVFS_DEPENDENCIES = host-pkgconf host-libglib2 libglib2 dbus shared-mime-info \
        $(TARGET_NLS_DEPENDENCIES)
 GVFS_LICENSE = LGPL-2.0+
 GVFS_LICENSE_FILES = COPYING
+GVFS_LIBS = $(TARGET_NLS_LIBS)
 
 # Export ac_cv_path_LIBGCRYPT_CONFIG unconditionally to prevent
 # build system from searching the host paths.
 GVFS_CONF_ENV = \
        ac_cv_path_LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config \
-       LIBS=$(TARGET_NLS_LIBS)
+       LIBS="$(GVFS_LIBS)"
 
 # Most of these are missing library support
 GVFS_CONF_OPTS = \
@@ -60,6 +61,7 @@ GVFS_CONF_OPTS += \
        --enable-archive \
        --with-archive-includes=$(STAGING_DIR)/usr \
        --with-archive-libs=$(STAGING_DIR)/usr
+GVFS_LIBS += `$(PKG_CONFIG_HOST_BINARY) --libs libarchive`
 else
 GVFS_CONF_OPTS += --disable-archive
 endif