package/gst1-shark: new package
authorChris Packham <judge.packham@gmail.com>
Fri, 25 Jan 2019 09:13:22 +0000 (22:13 +1300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 6 Feb 2019 10:29:26 +0000 (11:29 +0100)
GstShark leverages GStreamers newest instrumentation subsystem by
installing a set of custom hooks to the trace points. A variety of
data analytics are extracted and presented to the user in a graphical,
friendly way.

https://developer.ridgerun.com/wiki/index.php?title=GstShark
https://github.com/RidgeRun/gst-shark

Signed-off-by: Chris Packham <judge.packham@gmail.com>
Cc: Wolfgang Grandegger <wg@grandegger.com>
Cc: João Victor Oliveira <jv.oliveirag@gmail.com>
Cc: Adam Duskett <aduskett@gmail.com>
Cc: Igor Miranda <igorcmiranda3110@gmail.com>
[Thomas:
 - fix package prompt to be gtk1-shark in Config.in
 - license is LGPL-2.1+, not LGPL-2.1
 - add entry to DEVELOPERS file]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/gstreamer1/Config.in
package/gstreamer1/gst1-shark/Config.in [new file with mode: 0644]
package/gstreamer1/gst1-shark/gst1-shark.hash [new file with mode: 0644]
package/gstreamer1/gst1-shark/gst1-shark.mk [new file with mode: 0644]

index 65b6a09121a0d8e3d00f5b275d8c62246ea0ee26..1f3cc6a888b9a411e046b47c4462abd17714e86a 100644 (file)
@@ -461,6 +461,7 @@ F:  configs/orangepi_plus_defconfig
 
 N:     Chris Packham <judge.packham@gmail.com>
 F:     package/eventlog/
+F:     package/gstreamer1/gst1-shark/
 F:     package/micropython/
 F:     package/micropython-lib/
 F:     package/syslog-ng/
index 28b1ed25c56093359a2f8051baed6c1139918850..922ecefcffef57bf765c66067f7b3ade970976d2 100644 (file)
@@ -11,6 +11,7 @@ source "package/gstreamer1/gst1-imx/Config.in"
 source "package/gstreamer1/gst1-interpipe/Config.in"
 source "package/gstreamer1/gst1-libav/Config.in"
 source "package/gstreamer1/gst1-rtsp-server/Config.in"
+source "package/gstreamer1/gst1-shark/Config.in"
 source "package/gstreamer1/gst1-validate/Config.in"
 source "package/gstreamer1/gst1-vaapi/Config.in"
 source "package/gstreamer1/gst-omx/Config.in"
diff --git a/package/gstreamer1/gst1-shark/Config.in b/package/gstreamer1/gst1-shark/Config.in
new file mode 100644 (file)
index 0000000..9d656e2
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_GST1_SHARK
+       bool "gst1-shark"
+       select BR2_PACKAGE_GSTREAMER1_CHECK
+       select BR2_PACKAGE_GST1_PLUGINS_BASE
+       select BR2_PACKAGE_GST1_PLUGINS_BASE_PLUGIN_APP
+       help
+         GstShark leverages GStreamers newest instrumentation subsystem
+         by installing a set of custom hooks to the trace points. A
+         variety of data analytics are extracted and presented to the
+         user in a graphical, friendly way.
+
+         https://github.com/RidgeRun/gst-shark
diff --git a/package/gstreamer1/gst1-shark/gst1-shark.hash b/package/gstreamer1/gst1-shark/gst1-shark.hash
new file mode 100644 (file)
index 0000000..fdcbc56
--- /dev/null
@@ -0,0 +1,5 @@
+# locally computed hash
+sha256 35c56b89c10f42c623f5831f9533e1b9dcab8946eff0e4000bf3137bad5c705a  gst1-shark-v0.5.5.tar.gz
+
+# Hashes for license files:
+sha256 6d191b8f1fa03cabced18b8e48fddbf960a19f965bed8491e76ed62238f92f0b  COPYING
diff --git a/package/gstreamer1/gst1-shark/gst1-shark.mk b/package/gstreamer1/gst1-shark/gst1-shark.mk
new file mode 100644 (file)
index 0000000..1e198f0
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# gst1-shark
+#
+################################################################################
+
+GST1_SHARK_VERSION = v0.5.5
+GST1_SHARK_SITE =  https://github.com/RidgeRun/gst-shark.git
+GST1_SHARK_SITE_METHOD = git
+GST1_SHARK_GIT_SUBMODULES = YES
+
+GST1_SHARK_LICENSE = LGPL-2.1+
+GST1_SHARK_LICENSE_FILES = COPYING
+
+GST1_SHARK_AUTORECONF = YES
+GST1_SHARK_DEPENDENCIES = host-pkgconf gstreamer1 gst1-plugins-base
+GST1_SHARK_CONF_OPTS = --disable-graphviz
+
+$(eval $(autotools-package))