Fix install error caused by 'ln -sf' which tries to use the target's
author"Steven J. Hill" <sjhill@realitydiluted.com>
Sat, 23 Apr 2005 17:45:18 +0000 (17:45 -0000)
committer"Steven J. Hill" <sjhill@realitydiluted.com>
Sat, 23 Apr 2005 17:45:18 +0000 (17:45 -0000)
'ln' instead of the host. A quick grep through the other packages
shows that this may be an issue as well. I will probably have more
fixes later today.

package/bash/bash.mk

index d25b1558e8bad18a904153227712605f0b1920ce..dd14179779286b156ff1fdceca4387c8c9ee14ec 100644 (file)
@@ -59,7 +59,7 @@ $(TARGET_DIR)/$(BASH_TARGET_BINARY): $(BASH_DIR)/$(BASH_BINARY)
        $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BASH_DIR) install
        rm -f $(TARGET_DIR)/bin/bash*
        mv $(TARGET_DIR)/usr/bin/bash* $(TARGET_DIR)/bin/
-       (cd $(TARGET_DIR)/bin; ln -fs bash sh)
+       (cd $(TARGET_DIR)/bin; /bin/ln -fs bash sh)
        rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
                $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc