python-ptyprocess: new package
authorJan Viktorin <viktorin@rehivetech.com>
Sun, 27 Mar 2016 01:31:22 +0000 (03:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 15 Apr 2016 20:41:30 +0000 (22:41 +0200)
Signed-off-by: Jan Viktorin <viktorin@rehivetech.com>
[Thomas:
 - fix hash file
 - fix <pkg>_SITE variable.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-ptyprocess/Config.in [new file with mode: 0644]
package/python-ptyprocess/python-ptyprocess.hash [new file with mode: 0644]
package/python-ptyprocess/python-ptyprocess.mk [new file with mode: 0644]

index c1dccfd4c30967827c92e602c38bd5c30ffb4cea..25b43c0dbbecc70850f81f6b0b1991319f37abe2 100644 (file)
@@ -691,6 +691,7 @@ menu "External python modules"
        source "package/python-posix-ipc/Config.in"
        source "package/python-protobuf/Config.in"
        source "package/python-psutil/Config.in"
+       source "package/python-ptyprocess/Config.in"
        source "package/python-pyasn/Config.in"
        source "package/python-pyasn-modules/Config.in"
        source "package/python-pycli/Config.in"
diff --git a/package/python-ptyprocess/Config.in b/package/python-ptyprocess/Config.in
new file mode 100644 (file)
index 0000000..b95dacb
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_PTYPROCESS
+       bool "python-ptyprocess"
+       help
+         Launch a subprocess in a pseudo terminal (pty), and interact
+         with both the process and its pty.
+
+         https://github.com/pexpect/ptyprocess
diff --git a/package/python-ptyprocess/python-ptyprocess.hash b/package/python-ptyprocess/python-ptyprocess.hash
new file mode 100644 (file)
index 0000000..0e2e0ae
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org, sha256 locally computed
+md5    94e537122914cc9ec9c1eadcd36e73a1 ptyprocess-0.5.1.tar.gz
+sha256 0530ce63a9295bfae7bd06edc02b6aa935619f486f0f1dc0972f516265ee81a6  ptyprocess-0.5.1.tar.gz
diff --git a/package/python-ptyprocess/python-ptyprocess.mk b/package/python-ptyprocess/python-ptyprocess.mk
new file mode 100644 (file)
index 0000000..59329d0
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-ptyprocess
+#
+################################################################################
+
+PYTHON_PTYPROCESS_VERSION = 0.5.1
+PYTHON_PTYPROCESS_SITE = https://pypi.python.org/packages/source/p/ptyprocess
+PYTHON_PTYPROCESS_SOURCE = ptyprocess-$(PYTHON_PTYPROCESS_VERSION).tar.gz
+PYTHON_PTYPROCESS_LICENSE = ISC
+PYTHON_PTYPROCESS_LICENSE_FILES = LICENSE
+PYTHON_PTYPROCESS_SETUP_TYPE = distutils
+
+$(eval $(python-package))