rpm: add optional dependencies on elfutils and binutils
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 8 Dec 2016 23:04:05 +0000 (00:04 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 8 Dec 2016 23:04:57 +0000 (00:04 +0100)
Since these are detected by the configure script, we should explicit
their dependencies in rpm.mk.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rpm/rpm.mk

index accb625eb920dfeeb10865a1747cf9bf8757490c..2e829d751a25cb859c021d5eced27570034ab0cb 100644 (file)
@@ -65,6 +65,16 @@ else
 RPM_CONF_OPTS += --without-selinux
 endif
 
+# For the elfutils and binutils dependencies, there are no
+# configuration options to explicitly enable/disable them.
+ifeq ($(BR2_PACKAGE_ELFUTILS),y)
+RPM_DEPENDENCIES += elfutils
+endif
+
+ifeq ($(BR2_PACKAGE_BINUTILS),y)
+RPM_DEPENDENCIES += binutils
+endif
+
 # RPM, when using NLS, requires GNU gettext's _nl_msg_cat_cntr, which is not
 # provided in musl.
 ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)