toolchain-external: update Arm AArch64 BE toolchain 9.2-2019.12
authorRomain Naour <romain.naour@gmail.com>
Tue, 7 Jan 2020 21:30:14 +0000 (22:30 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 8 Jan 2020 08:31:48 +0000 (09:31 +0100)
Update to gcc 9.2.1, gdb 8.3.0, binutils 2.33.1.

The download url has been fixed:
https://bugs.linaro.org/show_bug.cgi?id=5529

See "Release Note":
https://developer.arm.com/open-source/gnu-toolchain/gnu-a/downloads#

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
toolchain/toolchain-external/toolchain-external-arm-aarch64-be/Config.in
toolchain/toolchain-external/toolchain-external-arm-aarch64-be/Config.in.options
toolchain/toolchain-external/toolchain-external-arm-aarch64-be/toolchain-external-arm-aarch64-be.hash
toolchain/toolchain-external/toolchain-external-arm-aarch64-be/toolchain-external-arm-aarch64-be.mk

index 130eca89d5591d449b758ab719fa9ad0a6dbf086..ea63687c5b9cdb45e2258784ec8997d9b7703d0f 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_TOOLCHAIN_EXTERNAL_ARM_AARCH64_BE
-       bool "Arm AArch64 BE 2019.03"
+       bool "Arm AArch64 BE 2019.12"
        depends on BR2_aarch64_be
        depends on BR2_HOSTARCH = "x86_64"
        depends on !BR2_STATIC_LIBS
@@ -7,8 +7,8 @@ config BR2_TOOLCHAIN_EXTERNAL_ARM_AARCH64_BE
        select BR2_TOOLCHAIN_HAS_SSP
        select BR2_INSTALL_LIBSTDCPP
        select BR2_TOOLCHAIN_HAS_NATIVE_RPC
-       select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_19
-       select BR2_TOOLCHAIN_GCC_AT_LEAST_8
+       select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_20
+       select BR2_TOOLCHAIN_GCC_AT_LEAST_9
        select BR2_TOOLCHAIN_HAS_FORTRAN
        select BR2_TOOLCHAIN_HAS_OPENMP
        help
index add4adad2a2865fa99547e4e619c7e70d1f75f9f..745af8a29ea1b9178c15016165f1bfb432b150ee 100644 (file)
@@ -1,7 +1,7 @@
 if BR2_TOOLCHAIN_EXTERNAL_ARM_AARCH64_BE
 
 config BR2_TOOLCHAIN_EXTERNAL_PREFIX
-       default "aarch64_be-linux-gnu"
+       default "aarch64_be-none-linux-gnu"
 
 config BR2_PACKAGE_PROVIDES_TOOLCHAIN_EXTERNAL
        default "toolchain-external-arm-aarch64-be"
index e20885e43e3a9bbbfe01653e38455ddf8df1e8f8..a82c2ba48387715b41ab2081e23f4c79f167c92b 100644 (file)
@@ -1,4 +1,4 @@
-# From https://developer.arm.com/-/media/Files/downloads/gnu-a/8.3-2019.03/binrel/gcc-arm-8.3-2019.03-x86_64-aarch64_be-linux-gnu.tar.xz.asc
-md5 51301481db36aa743213e8cd16dfa1e7 gcc-arm-8.3-2019.03-x86_64-aarch64_be-linux-gnu.tar.xz
+# From https://developer.arm.com/-/media/Files/downloads/gnu-a/9.2-2019.12/binrel/gcc-arm-9.2-2019.12-x86_64-aarch64_be-none-linux-gnu.tar.xz.asc
+md5 f9885977e7f949f35bc0820f4bf99ab2 gcc-arm-9.2-2019.12-x86_64-aarch64_be-none-linux-gnu.tar.xz
 # locally calculated
-sha256 5689d3cbb019144e55162c6b414ee1fc8362d9a21fbedadc49951ae97f95e62c gcc-arm-8.3-2019.03-x86_64-aarch64_be-linux-gnu.tar.xz
+sha256 55fc54a63567a35fb8280dfef91d50c0b5ad65aaea267f34fe7647b02d912f56 gcc-arm-9.2-2019.12-x86_64-aarch64_be-none-linux-gnu.tar.xz
index 9aed38a8cad52e0e7ac86a5278a69ef5ba790ede..e06f122991ba8591f97e16d4c671367164f748bf 100644 (file)
@@ -4,9 +4,9 @@
 #
 ################################################################################
 
-TOOLCHAIN_EXTERNAL_ARM_AARCH64_BE_VERSION = 2019.03
-TOOLCHAIN_EXTERNAL_ARM_AARCH64_BE_SITE = https://developer.arm.com/-/media/Files/downloads/gnu-a/8.3-$(TOOLCHAIN_EXTERNAL_ARM_AARCH64_BE_VERSION)/binrel
+TOOLCHAIN_EXTERNAL_ARM_AARCH64_BE_VERSION = 2019.12
+TOOLCHAIN_EXTERNAL_ARM_AARCH64_BE_SITE = https://developer.arm.com/-/media/Files/downloads/gnu-a/9.2-$(TOOLCHAIN_EXTERNAL_ARM_AARCH64_BE_VERSION)/binrel
 
-TOOLCHAIN_EXTERNAL_ARM_AARCH64_BE_SOURCE = gcc-arm-8.3-$(TOOLCHAIN_EXTERNAL_ARM_AARCH64_BE_VERSION)-x86_64-aarch64_be-linux-gnu.tar.xz
+TOOLCHAIN_EXTERNAL_ARM_AARCH64_BE_SOURCE = gcc-arm-9.2-$(TOOLCHAIN_EXTERNAL_ARM_AARCH64_BE_VERSION)-x86_64-aarch64_be-none-linux-gnu.tar.xz
 
 $(eval $(toolchain-external-package))