toolchain: only fetch gcc/gmp/mpfr/mpc when using a buildroot toolchain
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 17 Jan 2011 12:13:42 +0000 (09:13 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 19 Jan 2011 16:19:42 +0000 (17:19 +0100)
Closes #3103

gcc/gmp/mpfr/mpc are only needed when using an internal buildroot toolchain,
so only add them to HOST_SOURCE then.

Otherwise we get some nasty fetch error when doing "make source"

[Peter: add gmpc/mpfr/mpc and reword commit text]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
toolchain/gcc/gcc-uclibc-4.x.mk

diff --git a/CHANGES b/CHANGES
index baddfadc7e74b556cc33d313228afa13e1e534ec..a8255117ff4414134aafdab485e7863523884f0f 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -44,6 +44,7 @@
        #2965: Broken linkage to xkbcomp (blocking X server startup)
        #2983: xlib_libX11 build failed
        #3007: kexec doesn't build: Missing regdef.h file
+       #3103: make external-deps wants to download gcc-.tar.bz2 when...
        #3109: abnormal `make busybox-menuconfig`
 
 2010.11, Released November 30th, 2010:
index 80bed5eff4e3b8e1588657f5d11bdf1fd3af1663..2c857dce59479ac0a4c3f72d6cb40b62eaca39c2 100644 (file)
@@ -109,12 +109,16 @@ endif
 
 GCC_WITH_HOST_GMP = --with-gmp=$(HOST_DIR)/usr
 GCC_WITH_HOST_MPFR = --with-mpfr=$(HOST_DIR)/usr
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
 HOST_SOURCE += host-gmp-source host-mpfr-source
+endif
 GCC_HOST_PREREQ = host-gmp host-mpfr
 
 ifeq ($(findstring x4.5.,x$(GCC_VERSION)),x4.5.)
 GCC_WITH_HOST_MPC = --with-mpc=$(HOST_DIR)/usr
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
 HOST_SOURCE += host-mpc-source
+endif
 GCC_HOST_PREREQ += host-mpc
 endif
 
@@ -152,7 +156,9 @@ GCC_CONF_ENV:=acx_cv_prog_cc_pedantic__Wno_long_long__Wno_variadic_macros_______
        acx_cv_prog_cc_warning__Wno_overlength_strings=no
 endif
 
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
 HOST_SOURCE+=gcc-source
+endif
 
 $(DL_DIR)/$(GCC_SOURCE):
        mkdir -p $(DL_DIR)