package/openocd: depends on libftdi1 instead of libftdi
authorSamuel Martin <s.martin49@gmail.com>
Tue, 17 Mar 2015 17:36:36 +0000 (18:36 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 20 Mar 2015 22:30:08 +0000 (23:30 +0100)
Note that, if both libftdi and libftdi1 are available, openocd will
prefer libftdi1, so does Buildroot. ;-)

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openocd/Config.in
package/openocd/openocd.mk

index 7c140c7d042159de209a10c44b39d19e8da491e8..2db17fa76a1a7ad3116bf16279a89cf52a8a1b0a 100644 (file)
@@ -121,7 +121,7 @@ config BR2_PACKAGE_OPENOCD_PARPORT
 
 config BR2_PACKAGE_OPENOCD_FT2XXX
        bool "FT2232 based devices (DEPRECATED)"
-       select BR2_PACKAGE_LIBFTDI
+       select BR2_PACKAGE_LIBFTDI1
        depends on BR2_TOOLCHAIN_HAS_THREADS # libftdi -> libusb
        depends on BR2_ARCH_HAS_ATOMICS
        help
@@ -135,7 +135,7 @@ config BR2_PACKAGE_OPENOCD_VPI
 
 config BR2_PACKAGE_OPENOCD_UBLASTER
        bool "Altera USB-Blaster"
-       select BR2_PACKAGE_LIBFTDI
+       select BR2_PACKAGE_LIBFTDI1
        depends on BR2_TOOLCHAIN_HAS_THREADS # libftdi -> libusb
        depends on BR2_ARCH_HAS_ATOMICS
        help
@@ -176,7 +176,7 @@ config BR2_PACKAGE_OPENOCD_GW16012
 
 config BR2_PACKAGE_OPENOCD_PRESTO
        bool "ASIX Presto Programmer"
-       select BR2_PACKAGE_LIBFTDI
+       select BR2_PACKAGE_LIBFTDI1
        depends on BR2_TOOLCHAIN_HAS_THREADS # libftdi -> libusb
        depends on BR2_ARCH_HAS_ATOMICS
        help
@@ -185,7 +185,7 @@ config BR2_PACKAGE_OPENOCD_PRESTO
 
 config BR2_PACKAGE_OPENOCD_OPENJTAG
        bool "OpenJTAG Programmer"
-       select BR2_PACKAGE_LIBFTDI
+       select BR2_PACKAGE_LIBFTDI1
        depends on BR2_TOOLCHAIN_HAS_THREADS # libftdi -> libusb
        depends on BR2_ARCH_HAS_ATOMICS
        help
index fd7e09fad621070282d8aa22d660eb20bf6d103c..3b7685061bf4cb3e0c1ff5472d0fbd10baea8644 100644 (file)
@@ -23,7 +23,7 @@ OPENOCD_CONF_OPTS = \
 # the dependencies they need.
 
 OPENOCD_DEPENDENCIES = \
-       $(if $(BR2_PACKAGE_LIBFTDI),libftdi) \
+       $(if $(BR2_PACKAGE_LIBFTDI1),libftdi1) \
        $(if $(BR2_PACKAGE_LIBUSB),libusb) \
        $(if $(BR2_PACKAGE_LIBUSB_COMPAT),libusb-compat) \
        $(if $(BR2_PACKAGE_LIBHID),libhid)