gcc: fix HOST_GCC_COMMON_WRAPPER_TARGET_FLOAT_ABI typos
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 4 Apr 2018 15:54:50 +0000 (17:54 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 9 Apr 2018 09:26:41 +0000 (11:26 +0200)
The HOST_GCC_COMMON_WRAPPER_TARGET_FLOAT_ABI variable was incorrectly
used as HOST_GCC_COMMON_WRAPPER_TARGET_FLOATABI_, which would always
be empty.

In practice, this block of code is only used on Blackfin (which has
BR2_GCC_ARCH_HAS_CONFIGURABLE_DEFAULTS unset) and Blackfin doesn't use
float-abi, so this block of code is in fact useless. But even if it's
useless, it's better to have it without typos.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gcc/gcc.mk

index f42f36a967a699fe33cd59d944357832eba04d6d..5a1e3d5b0c69ce83a67864c0703e5d9d578f0d43 100644 (file)
@@ -297,8 +297,8 @@ endif
 ifneq ($(HOST_GCC_COMMON_WRAPPER_TARGET_FPU),)
 HOST_GCC_COMMON_TOOLCHAIN_WRAPPER_ARGS += -DBR_FPU='"$(HOST_GCC_COMMON_WRAPPER_TARGET_FPU)"'
 endif
-ifneq ($(HOST_GCC_COMMON_WRAPPER_TARGET_FLOATABI_),)
-HOST_GCC_COMMON_TOOLCHAIN_WRAPPER_ARGS += -DBR_FLOAT_ABI='"$(HOST_GCC_COMMON_WRAPPER_TARGET_FLOATABI_)"'
+ifneq ($(HOST_GCC_COMMON_WRAPPER_TARGET_FLOAT_ABI),)
+HOST_GCC_COMMON_TOOLCHAIN_WRAPPER_ARGS += -DBR_FLOAT_ABI='"$(HOST_GCC_COMMON_WRAPPER_TARGET_FLOAT_ABI)"'
 endif
 ifneq ($(HOST_GCC_COMMON_WRAPPER_TARGET_MODE),)
 HOST_GCC_COMMON_TOOLCHAIN_WRAPPER_ARGS += -DBR_MODE='"$(HOST_GCC_COMMON_WRAPPER_TARGET_MODE)"'