package/thrift: force boost libdir to staging/usr/lib/
authorRomain Naour <romain.naour@openwide.fr>
Mon, 23 Feb 2015 23:29:07 +0000 (00:29 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 8 Mar 2015 21:41:38 +0000 (22:41 +0100)
Libtool append the sysroot path (lt_sysroot) with the libdir value found in
the libstdc++.la file only with bfin toolchain.

Path/to/sysroot/opt/uClinux/bfin-linux-uclibc/lib/gcc/bfin-linux-uclibc/4.3.5/libstdc++.so

The issue disappears when --with-boost=$(STAGING_DIR) is removed.
So instead of using --with-boost=$(STAGING_DIR), use
--with-boost-libdir=$(STAGING_DIR)/usr/lib to give the path to boost's
libraries.

Fixes:
http://autobuild.buildroot.net/results/ae2/ae274693b953dd569c3ff63c532e2fc9553b5002/

And many more

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/thrift/thrift.mk

index 559bd28850cba6a9402cbd312833cf0239eb03d6..094f8d05c5e05e17dcc4c374200cbd9122cbcca3 100644 (file)
@@ -11,7 +11,8 @@ THRIFT_INSTALL_STAGING = YES
 HOST_THRIFT_DEPENDENCIES = host-boost host-libevent host-openssl host-pkgconf \
        host-zlib host-bison host-flex
 THRIFT_CONF_OPTS = --with-sysroot=$(STAGING_DIR) \
-       --with-boost=$(STAGING_DIR) \
+       --with-boost \
+       --with-boost-libdir=$(STAGING_DIR)/usr/lib \
        --disable-tests \
        --disable-tutorial
 HOST_THRIFT_CONF_OPTS = --with-sysroot=$(HOST_DIR) \