package/libevent: Fix broken download URL
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 18 Jan 2016 17:38:40 +0000 (18:38 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 18 Jan 2016 18:48:38 +0000 (19:48 +0100)
Upstream URL has changed on Sourceforge:

>>> libevent 2.0.22-stable Downloading
--2016-01-17 23:06:31--  http://downloads.sourceforge.net/project/levent/libevent/libevent-2.0/libevent-2.0.22-stable.tar.gz
Resolving downloads.sourceforge.net (downloads.sourceforge.net)... 216.34.181.59
Connecting to downloads.sourceforge.net (downloads.sourceforge.net)|216.34.181.59|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2016-01-17 23:06:31 ERROR 404: Not Found.

Additionally the project moved to github:
http://sourceforge.net/projects/levent/

"As of 2015-10-07, this project may now be found at
 https://github.com/libevent/libevent."

This patch points Config.in to the new upstream URL and fixes the broken
download URL by using github.com.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libevent/Config.in
package/libevent/libevent.mk

index 680fa48571fa25ede3fa0b0e9ad12bce74cc5dd5..c32f29e5b021de7a7f24fa25739841b2f48db32a 100644 (file)
@@ -3,4 +3,4 @@ config BR2_PACKAGE_LIBEVENT
        help
          Userspace library for handling asynchronous notifications
 
-         http://monkey.org/~provos/
+         http://libevent.org
index d67c73833bf1a0f548245e3f77daf25ce5137837..820beea9c54d6acfeefa1e2a74a37ecef2ab8211 100644 (file)
@@ -4,9 +4,8 @@
 #
 ################################################################################
 
-LIBEVENT_VERSION_MAJOR = 2.0
-LIBEVENT_VERSION = $(LIBEVENT_VERSION_MAJOR).22-stable
-LIBEVENT_SITE = http://downloads.sourceforge.net/project/levent/libevent/libevent-$(LIBEVENT_VERSION_MAJOR)
+LIBEVENT_VERSION = 2.0.22-stable
+LIBEVENT_SITE = https://github.com/libevent/libevent/releases/download/release-$(LIBEVENT_VERSION)
 LIBEVENT_INSTALL_STAGING = YES
 LIBEVENT_LICENSE = BSD-3c, OpenBSD
 LIBEVENT_LICENSE_FILES = LICENSE