cppzmq: bump to version v4.3.0
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 20 Sep 2018 22:03:19 +0000 (00:03 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 25 Sep 2018 21:21:08 +0000 (23:21 +0200)
- move to cmake-infrastructure
- add patch to fix install without static libzmq
- add hash for license file

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/cppzmq/0001-fix-install-without-static-libzmq.patch [new file with mode: 0644]
package/cppzmq/cppzmq.hash
package/cppzmq/cppzmq.mk

diff --git a/package/cppzmq/0001-fix-install-without-static-libzmq.patch b/package/cppzmq/0001-fix-install-without-static-libzmq.patch
new file mode 100644 (file)
index 0000000..15936f3
--- /dev/null
@@ -0,0 +1,47 @@
+From bffb0eda34195339f2af49f2879d9d0b9dee5c28 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Thu, 20 Sep 2018 19:37:26 +0200
+Subject: [PATCH] fix install without static libzmq
+
+If libzmq is only available as a shared library and not a static one
+then cmake fails with:
+
+-- CMake libzmq package not found, trying again with pkg-config (normal install of zeromq)
+-- Found PkgConfig: /home/fabrice/buildroot/output/host/bin/pkg-config (found version "0.28")
+CMake Error at CMakeLists.txt:20 (message):
+  ZeroMQ was not found, neither as a CMake package nor via pkg-config
+
+This is due to the fact that ZeroMQ_FOUND is not set to ON even if
+ZEROMQ_LIBRARY is TRUE:
+
+if(ZeroMQ_LIBRARY AND ZeroMQ_STATIC_LIBRARY)
+    set(ZeroMQ_FOUND ON)
+endif()
+
+So change AND by OR as suggested in
+https://github.com/zeromq/cppzmq/issues/266
+
+Fix #266
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Upstream status: https://github.com/zeromq/cppzmq/pull/267]
+---
+ libzmq-pkg-config/FindZeroMQ.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libzmq-pkg-config/FindZeroMQ.cmake b/libzmq-pkg-config/FindZeroMQ.cmake
+index 89d8236..1b84c95 100644
+--- a/libzmq-pkg-config/FindZeroMQ.cmake
++++ b/libzmq-pkg-config/FindZeroMQ.cmake
+@@ -8,7 +8,7 @@ find_library(ZeroMQ_LIBRARY NAMES libzmq.so libzmq.dylib libzmq.dll
+ find_library(ZeroMQ_STATIC_LIBRARY NAMES libzmq-static.a libzmq.a libzmq.dll.a
+              PATHS ${PC_LIBZMQ_LIBDIR} ${PC_LIBZMQ_LIBRARY_DIRS})
+-if(ZeroMQ_LIBRARY AND ZeroMQ_STATIC_LIBRARY)
++if(ZeroMQ_LIBRARY OR ZeroMQ_STATIC_LIBRARY)
+     set(ZeroMQ_FOUND ON)
+ endif()
+-- 
+2.17.1
+
index 792fb17b2f3757ae6fb4730352c4d2e375709beb..52308d1ea67377ed5c4a463ecd3b8343dcc59bf1 100644 (file)
@@ -1,2 +1,3 @@
 # Locally calculated
-sha256 812b47f76c609e194b2607a186ff0d1b03b6a0c8ea13b20faa47570ddf38ef2c  cppzmq-68a7b09cfce01c4c279fba2cf91686fcfc566848.tar.gz
+sha256 27d1f56406ba94ee779e639203218820975cf68174f92fbeae0f645df0fcada4  cppzmq-v4.3.0.tar.gz
+sha256 7e6db90e2e805c72b3daa77849d1cb5f1f92da0e69750c8a4aa1d86d70704748  LICENSE
index 113b9a070e07ee97d91dc75d237df9df281c4768..d23366e1d3d9bda6351b2eb91b6b3eb87c907a45 100644 (file)
@@ -4,15 +4,12 @@
 #
 ################################################################################
 
-CPPZMQ_VERSION = 68a7b09cfce01c4c279fba2cf91686fcfc566848
+CPPZMQ_VERSION = v4.3.0
 CPPZMQ_SITE = $(call github,zeromq,cppzmq,$(CPPZMQ_VERSION))
 CPPZMQ_INSTALL_STAGING = YES
-CPPZMQ_DEPENDENCIES = zeromq
+CPPZMQ_DEPENDENCIES = host-pkgconf zeromq
 CPPZMQ_LICENSE = MIT
 CPPZMQ_LICENSE_FILES = LICENSE
+CPPZMQ_CONF_OPTS = -DCPPZMQ_BUILD_TESTS=OFF
 
-define CPPZMQ_INSTALL_STAGING_CMDS
-       $(INSTALL) -m 0644 -D $(@D)/zmq.hpp $(STAGING_DIR)/usr/include/zmq.hpp
-endef
-
-$(eval $(generic-package))
+$(eval $(cmake-package))