package/git: add optional support for pcre2
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 31 Oct 2017 18:36:57 +0000 (19:36 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 23 Nov 2017 22:20:05 +0000 (23:20 +0100)
Renamed --with-libpcre to --with-libpcre1. Currently --with-libpcre
activates pcre1 support but this can change in the future to pcre2:
https://github.com/git/git/blob/df7fd961a9d9ba60840ffc0868d36cc3db2aec74/configure.ac#L258

Please note that we cannot use --with-/--without because it will lead
to an error reported by configure, for example

    --with-libpcre1 --without-libpcre2

will produce

configure: error: Only supply one of --with-libpcre1 or --with-libpcre2!

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/git/git.mk

index 181e7421e220833162346452a895891e215fa8c4..6269dc570e570cb50366a4aad814df97bccdf1c2 100644 (file)
@@ -19,9 +19,12 @@ else
 GIT_CONF_OPTS += --without-openssl
 endif
 
-ifeq ($(BR2_PACKAGE_PCRE),y)
+ifeq ($(BR2_PACKAGE_PCRE2),y)
+GIT_DEPENDENCIES += pcre2
+GIT_CONF_OPTS += --with-libpcre2
+else ifeq ($(BR2_PACKAGE_PCRE),y)
 GIT_DEPENDENCIES += pcre
-GIT_CONF_OPTS += --with-libpcre
+GIT_CONF_OPTS += --with-libpcre1
 GIT_MAKE_OPTS += NO_LIBPCRE1_JIT=1
 else
 GIT_CONF_OPTS += --without-libpcre