perl-cookie-baker: new package
authorFrancois Perrad <fperrad@gmail.com>
Sat, 6 Oct 2018 16:55:19 +0000 (18:55 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 8 Oct 2018 10:23:49 +0000 (12:23 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/Config.in
package/perl-cookie-baker/Config.in [new file with mode: 0644]
package/perl-cookie-baker/perl-cookie-baker.hash [new file with mode: 0644]
package/perl-cookie-baker/perl-cookie-baker.mk [new file with mode: 0644]

index d68ecaef3fbb4401bd1058e2d225e42df5c51aa8..309a9cfeccbc144111771cdb6aed88e745f537c3 100644 (file)
@@ -673,6 +673,7 @@ menu "Perl libraries/modules"
        source "package/perl-class-std/Config.in"
        source "package/perl-class-std-fast/Config.in"
        source "package/perl-convert-asn1/Config.in"
+       source "package/perl-cookie-baker/Config.in"
        source "package/perl-crypt-blowfish/Config.in"
        source "package/perl-crypt-cbc/Config.in"
        source "package/perl-crypt-openssl-random/Config.in"
diff --git a/package/perl-cookie-baker/Config.in b/package/perl-cookie-baker/Config.in
new file mode 100644 (file)
index 0000000..e6846a2
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PERL_COOKIE_BAKER
+       bool "perl-cookie-baker"
+       select BR2_PACKAGE_PERL_URI
+       help
+         Cookie string generator / parser
+
+         https://github.com/kazeburo/Cookie-Baker
diff --git a/package/perl-cookie-baker/perl-cookie-baker.hash b/package/perl-cookie-baker/perl-cookie-baker.hash
new file mode 100644 (file)
index 0000000..8d0d63b
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    20f6f16689df949db86645652c1ebe38 Cookie-Baker-0.10.tar.gz
+sha256 b42bad15b12da4cdc5c90c902faf3ad484281a42203fa4e7652866434f6fa4dd Cookie-Baker-0.10.tar.gz
+
+# computed by scancpan
+sha256 b4ce94671fa219074d4e91e2268652d6bf9764cebcc7a5e27bfc14897745ca4c LICENSE
diff --git a/package/perl-cookie-baker/perl-cookie-baker.mk b/package/perl-cookie-baker/perl-cookie-baker.mk
new file mode 100644 (file)
index 0000000..31410ee
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-cookie-baker
+#
+################################################################################
+
+PERL_COOKIE_BAKER_VERSION = 0.10
+PERL_COOKIE_BAKER_SOURCE = Cookie-Baker-$(PERL_COOKIE_BAKER_VERSION).tar.gz
+PERL_COOKIE_BAKER_SITE = $(BR2_CPAN_MIRROR)/authors/id/K/KA/KAZEBURO
+PERL_COOKIE_BAKER_DEPENDENCIES = host-perl-module-build-tiny perl-uri
+PERL_COOKIE_BAKER_LICENSE = Artistic or GPL-1.0+
+PERL_COOKIE_BAKER_LICENSE_FILES = LICENSE
+
+$(eval $(perl-package))