x11vnc: fix build without ipv6 support
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 26 Sep 2012 21:15:48 +0000 (23:15 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 26 Sep 2012 21:24:14 +0000 (23:24 +0200)
Fixes http://autobuild.buildroot.net/results/1119dbf055edf281451a9e4216fdebc0b07fffae/

configure script uses --without-ipv6 instead of --disable-ipv6, and configure
option is only used for libraries, not the x11vnc application.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/x11vnc/x11vnc.mk

index 444a839622155211aad5f897dbe2828a8125ca2a..51ae0a0fb20f29189acbfc23d8a52f5a788f268a 100644 (file)
@@ -11,4 +11,10 @@ X11VNC_CONF_OPT = \
 
 X11VNC_DEPENDENCIES = xlib_libXt xlib_libXext
 
+ifneq ($(BR2_INET_IPV6),y)
+# configure option only used for libvncserver
+X11VNC_CONF_OPT += --without-ipv6
+X11VNC_CONF_ENV += CFLAGS='$(TARGET_CFLAGS) -DX11VNC_IPV6=0'
+endif
+
 $(eval $(autotools-package))