package/qemu: add optional spice support
authorJared Bents <jared.bents@rockwellcollins.com>
Mon, 29 Jun 2020 20:50:00 +0000 (15:50 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 13 Jul 2020 21:30:20 +0000 (23:30 +0200)
Signed-off-by: Jared Bents <jared.bents@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qemu/qemu.mk

index cb138fd4883526f9ab27707c41273e1ccd567633..c013e6ffa015c62dceccad0c359ca09c664aed4c 100644 (file)
@@ -112,6 +112,13 @@ else
 QEMU_OPTS += --disable-numa
 endif
 
+ifeq ($(BR2_PACKAGE_SPICE),y)
+QEMU_OPTS += --enable-spice
+QEMU_DEPENDENCIES += spice
+else
+QEMU_OPTS += --disable-spice
+endif
+
 # Override CPP, as it expects to be able to call it like it'd
 # call the compiler.
 define QEMU_CONFIGURE_CMDS
@@ -143,7 +150,6 @@ define QEMU_CONFIGURE_CMDS
                        --disable-linux-io-uring \
                        --disable-cap-ng \
                        --disable-docs \
-                       --disable-spice \
                        --disable-rbd \
                        --disable-libiscsi \
                        --disable-usb-redir \