package/x11r7/xdriver_xf86-input-libinput: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 15 Mar 2015 11:19:23 +0000 (12:19 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 15 Mar 2015 13:22:16 +0000 (14:22 +0100)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/x11r7/Config.in
package/x11r7/xdriver_xf86-input-libinput/Config.in [new file with mode: 0644]
package/x11r7/xdriver_xf86-input-libinput/xdriver_xf86-input-libinput.hash [new file with mode: 0644]
package/x11r7/xdriver_xf86-input-libinput/xdriver_xf86-input-libinput.mk [new file with mode: 0644]

index f60c752ed982a7d7bf78214e390e1e55cf3d5401..608837fc7a936556e7df4cbf4910b7bf16dc320b 100644 (file)
@@ -146,6 +146,7 @@ if BR2_PACKAGE_XORG7
                source package/x11r7/xdriver_xf86-input-evdev/Config.in
                source package/x11r7/xdriver_xf86-input-joystick/Config.in
                source package/x11r7/xdriver_xf86-input-keyboard/Config.in
+               source package/x11r7/xdriver_xf86-input-libinput/Config.in
                source package/x11r7/xdriver_xf86-input-mouse/Config.in
                source package/x11r7/xdriver_xf86-input-synaptics/Config.in
                source package/x11r7/xdriver_xf86-input-tslib/Config.in
diff --git a/package/x11r7/xdriver_xf86-input-libinput/Config.in b/package/x11r7/xdriver_xf86-input-libinput/Config.in
new file mode 100644 (file)
index 0000000..cc878b6
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_XDRIVER_XF86_INPUT_LIBINPUT
+       bool "xf86-input-libinput"
+       depends on BR2_PACKAGE_HAS_UDEV # libinput
+       select BR2_PACKAGE_LIBINPUT
+       select BR2_PACKAGE_XPROTO_INPUTPROTO
+       select BR2_PACKAGE_XPROTO_XPROTO
+       help
+         This is an X driver based on libinput. It is a thin wrapper around
+         libinput, so while it does provide all features that libinput supports
+         it does little beyond.
+
+comment "xf86-input-libinput requires udev to be enabled"
+       depends on !BR2_PACKAGE_HAS_UDEV
diff --git a/package/x11r7/xdriver_xf86-input-libinput/xdriver_xf86-input-libinput.hash b/package/x11r7/xdriver_xf86-input-libinput/xdriver_xf86-input-libinput.hash
new file mode 100644 (file)
index 0000000..a07df47
--- /dev/null
@@ -0,0 +1,3 @@
+# From http://lists.x.org/archives/xorg-announce/2015-March/002540.html
+sha1   c2ec968847f85d7d503b12d63c2cc9697cbe0243                                xf86-input-libinput-0.8.0.tar.bz2
+sha256 2152b0984feffe8151934ad9af29bde7fc621e0a54b0cdedbaf1abc367dea43a        xf86-input-libinput-0.8.0.tar.bz2
diff --git a/package/x11r7/xdriver_xf86-input-libinput/xdriver_xf86-input-libinput.mk b/package/x11r7/xdriver_xf86-input-libinput/xdriver_xf86-input-libinput.mk
new file mode 100644 (file)
index 0000000..ec788a2
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# xdriver_xf86-input-libinput
+#
+################################################################################
+
+XDRIVER_XF86_INPUT_LIBINPUT_VERSION = 0.8.0
+XDRIVER_XF86_INPUT_LIBINPUT_SOURCE = xf86-input-libinput-$(XDRIVER_XF86_INPUT_LIBINPUT_VERSION).tar.bz2
+XDRIVER_XF86_INPUT_LIBINPUT_SITE = http://xorg.freedesktop.org/releases/individual/driver
+XDRIVER_XF86_INPUT_LIBINPUT_LICENSE = MIT
+XDRIVER_XF86_INPUT_LIBINPUT_LICENSE_FILES = COPYING
+XDRIVER_XF86_INPUT_LIBINPUT_DEPENDENCIES = libinput xserver_xorg-server xproto_inputproto xproto_xproto
+
+$(eval $(autotools-package))