package/systemd: don't fail if getty service directory already exists
authorBartosz Bilas <b.bilas@grinn-global.com>
Mon, 16 Nov 2020 12:30:35 +0000 (13:30 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 3 Jan 2021 09:02:12 +0000 (10:02 +0100)
Add -p argument that ignore that specified directory already exists.

Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
[yann.morin.1998@free.fr:
  - split to its own patch
  - rewrite commit title
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/systemd/systemd.mk

index 5aed87f452be8c56195512deb99f84b8419ebadc..51d0a7b5583ef7bd17990b430d78ecfd5ae397c0 100644 (file)
@@ -581,7 +581,7 @@ ifneq ($(call qstrip,$(BR2_TARGET_GENERIC_GETTY_PORT)),)
 # * enable serial-getty@xxx for other $BR2_TARGET_GENERIC_TTY_PATH
 # * rewrite baudrates if a baudrate is provided
 define SYSTEMD_INSTALL_SERVICE_TTY
-       mkdir $(TARGET_DIR)/usr/lib/systemd/system/getty@.service.d; \
+       mkdir -p $(TARGET_DIR)/usr/lib/systemd/system/getty@.service.d; \
        printf '[Install]\nDefaultInstance=\n' \
                >$(TARGET_DIR)/usr/lib/systemd/system/getty@.service.d/buildroot-console.conf; \
        if [ $(BR2_TARGET_GENERIC_GETTY_PORT) = "console" ]; \
@@ -593,7 +593,7 @@ define SYSTEMD_INSTALL_SERVICE_TTY
                        $(call qstrip,$(BR2_TARGET_GENERIC_GETTY_PORT)) \
                        >$(TARGET_DIR)/usr/lib/systemd/system/getty@.service.d/buildroot-console.conf; \
        else \
-               mkdir $(TARGET_DIR)/usr/lib/systemd/system/serial-getty@.service.d;\
+               mkdir -p $(TARGET_DIR)/usr/lib/systemd/system/serial-getty@.service.d;\
                printf '[Install]\nDefaultInstance=%s\n' \
                        $(call qstrip,$(BR2_TARGET_GENERIC_GETTY_PORT)) \
                        >$(TARGET_DIR)/usr/lib/systemd/system/serial-getty@.service.d/buildroot-console.conf;\