toolchain-external: introduce BR2_TOOLCHAIN_HAS_OPENMP
authorEd Blake <ed.blake@sondrel.com>
Tue, 26 Mar 2019 12:30:45 +0000 (12:30 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 26 Mar 2019 19:17:21 +0000 (20:17 +0100)
Add new BR2_TOOLCHAIN_HAS_OPENMP option for toolchains with OpenMP
support.

Signed-off-by: Ed Blake <ed.blake@sondrel.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
toolchain/Config.in
toolchain/toolchain-external/pkg-toolchain-external.mk

index 3f297f6b433ba7066ff7057138d01b6dce7fdfbd..552220123fef21666499253c5fd09c8b9d92088c 100644 (file)
@@ -168,6 +168,9 @@ config BR2_TOOLCHAIN_HAS_SSP
 config BR2_TOOLCHAIN_HAS_UCONTEXT
        bool
 
+config BR2_TOOLCHAIN_HAS_OPENMP
+       bool
+
 config BR2_TOOLCHAIN_SUPPORTS_PIE
        bool
 
index db3570d96ff07c9cee7916aacd9e6385f97e5a08..747837fdc68fb901f3485dbf99ffbd9c53ce629d 100644 (file)
@@ -144,6 +144,10 @@ TOOLCHAIN_EXTERNAL_LIBS += libquadmath.so*
 endif
 endif
 
+ifeq ($(BR2_TOOLCHAIN_HAS_OPENMP),y)
+TOOLCHAIN_EXTERNAL_LIBS += libgomp.so.*
+endif
+
 TOOLCHAIN_EXTERNAL_LIBS += $(call qstrip,$(BR2_TOOLCHAIN_EXTRA_EXTERNAL_LIBS))