toolchain/external: bump Linaro ARMeb to 2016.05 for i686 hosts
authorRomain Naour <romain.naour@gmail.com>
Tue, 11 Oct 2016 21:04:58 +0000 (23:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 16 Oct 2016 11:08:05 +0000 (13:08 +0200)
Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/toolchain-external.hash
toolchain/toolchain-external/toolchain-external.mk

index 964cc01d4bb5371664d78e2b0f1d655921a05659..eb01cf387fcd1d8ad08945432681ad5d58198073 100644 (file)
@@ -34,36 +34,11 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARM
          with the hard floating point calling convention, and uses
          the VFPv3-D16 FPU instructions.
 
-# See the note above.
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARMEB
-       bool "Linaro armeb 2014.09"
-       depends on BR2_armeb
-       depends on BR2_ARM_CPU_ARMV7A
-       depends on BR2_HOSTARCH = "x86"
-       depends on BR2_ARM_EABIHF
-       depends on !BR2_STATIC_LIBS
-       select BR2_TOOLCHAIN_EXTERNAL_GLIBC
-       select BR2_TOOLCHAIN_HAS_SSP
-       select BR2_TOOLCHAIN_HAS_NATIVE_RPC
-       select BR2_INSTALL_LIBSTDCPP
-       select BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_1
-       select BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
-       select BR2_TOOLCHAIN_HAS_FORTRAN
-       help
-         Linaro toolchain for the ARM big endian architecture. It
-         uses Linaro GCC 2014.09 (based on gcc 4.9), Linaro GDB
-         2013.10 (based on GDB 7.6), eglibc 2.19, Binutils 2014.09
-         (based on 2.24). It generates code that runs on all Cortex-A
-         profile devices, but tuned for the Cortex-A9. The code
-         generated is Thumb 2, with the hard floating point calling
-         convention, and uses the VFPv3-D16 FPU instructions.
-
-# See the note above.
 config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARMEB
        bool "Linaro armeb 2016.05"
        depends on BR2_armeb
        depends on BR2_ARM_CPU_ARMV7A
-       depends on BR2_HOSTARCH = "x86_64"
+       depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
        depends on BR2_ARM_EABIHF
        depends on !BR2_STATIC_LIBS
        select BR2_TOOLCHAIN_EXTERNAL_GLIBC
index b89b3464c841a6a33633c8ec039f88a4a1c6c8da..65be7ddd399d43dc3c167774f30002447e17ef28 100644 (file)
@@ -37,8 +37,7 @@ sha256 25fbf0513ad7322b15cbaae964cafadcbb4c939f2708f57f40b8f9f2d601122b  arago-t
 # ARM and Aarch64 toolchains from Linaro
 sha256 f1421c580ce977226f4fefc9c409b3b423260cc65a6e9dc6da88bb3478a521a0  gcc-linaro-5.3.1-2016.05-i686_arm-linux-gnueabihf.tar.xz
 sha256 987941c9fffdf56ffcbe90e8984673c16648c477b537fcf43add22fa62f161cd  gcc-linaro-5.3.1-2016.05-x86_64_arm-linux-gnueabihf.tar.xz
-sha256 4bc9d86390f8fa67a693ba4768ba5b12faaf7dd37c706c05ccd9321e765226e4  gcc-linaro-armeb-linux-gnueabihf-4.9-2014.09_linux.tar.xz
-sha256 bf5d3111dad5aa9aef0e955875fb7fc9e918cb24519af7014dd67a9e581a49b1  gcc-linaro-armeb-linux-gnueabihf-4.9-2014.09_src.tar.bz2
+sha256 f6e9c0d3320760fe8f89e9ec3acdd7b4da7eff889c094b4a2acc286fd46f334f  gcc-linaro-5.3.1-2016.05-i686_armeb-linux-gnueabihf.tar.xz
 sha256 6cf41c8944be56279cc14992aa075174b7a4c5938502536266eaaeef048f9440  gcc-linaro-5.3.1-2016.05-x86_64_armeb-linux-gnueabihf.tar.xz
 sha256 3954f496ab01de67241109e82abfaa9b7625fdab4f05e79e7902e9814a07b832  gcc-linaro-aarch64-linux-gnu-4.9-2014.09_linux.tar.xz
 sha256 a7b8f842fdc9d9be22ca4e0c999429780fc6f16ea798b032421b5ec0cfa53b3e  gcc-linaro-aarch64-linux-gnu-4.9-2014.09_src.tar.bz2
index d7fa9dfba18ad4174420e2f5b2e1952f06617c98..fd1e75a9ed4287c79a8e3b3dac5aa92d83f5c56c 100644 (file)
@@ -336,13 +336,10 @@ else
 TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-5.3.1-2016.05-x86_64_arm-linux-gnueabihf.tar.xz
 endif
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_ARMEB),y)
+TOOLCHAIN_EXTERNAL_SITE = https://releases.linaro.org/components/toolchain/binaries/5.3-2016.05/armeb-linux-gnueabihf
 ifeq ($(HOSTARCH),x86)
-TOOLCHAIN_EXTERNAL_SITE = https://releases.linaro.org/14.09/components/toolchain/binaries
-TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-armeb-linux-gnueabihf-4.9-2014.09_linux.tar.xz
-TOOLCHAIN_EXTERNAL_ACTUAL_SOURCE_TARBALL = gcc-linaro-armeb-linux-gnueabihf-4.9-2014.09_src.tar.bz2
-TOOLCHAIN_EXTERNAL_POST_INSTALL_STAGING_HOOKS += TOOLCHAIN_EXTERNAL_LINARO_SYMLINK
+TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-5.3.1-2016.05-i686_armeb-linux-gnueabihf.tar.xz
 else
-TOOLCHAIN_EXTERNAL_SITE = https://releases.linaro.org/components/toolchain/binaries/5.3-2016.05/armeb-linux-gnueabihf
 TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-5.3.1-2016.05-x86_64_armeb-linux-gnueabihf.tar.xz
 endif
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS),y)