package/genpart: make it a target package, too
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 20 Sep 2014 21:48:25 +0000 (23:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Sep 2014 19:16:28 +0000 (21:16 +0200)
genpart comes handy when there is a need to programatically generate
partition tables, without the need for a full partitioning program like
fdisk et al.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/genpart/Config.in [new file with mode: 0644]
package/genpart/genpart.mk

index b10225b3849665b2177970dab32e80c9c8815eb6..39a5c6f860f36a1bf05350912d9b5215aaf48aaa 100644 (file)
@@ -150,6 +150,7 @@ menu "Filesystem and flash utilities"
        source "package/f2fs-tools/Config.in"
        source "package/flashbench/Config.in"
        source "package/genext2fs/Config.in"
+       source "package/genpart/Config.in"
        source "package/genromfs/Config.in"
        source "package/kobs-ng/Config.in"
        source "package/makedevs/Config.in"
diff --git a/package/genpart/Config.in b/package/genpart/Config.in
new file mode 100644 (file)
index 0000000..8d9ec79
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_GENPART
+       bool "genpart"
+       help
+         Generate a 16 byte partition table entry defined by command line
+         arguments and dump it to stdout. No CHS magic is done, only lba
+         entries are filled out.
+
+         http://www.pengutronix.de/software/genpart/index_en.html
index c95acaf1b323cdf5359485eed32e4e0ed7368815..e2208b83d0d32f6b1d26f0e529b4913e24dfdab4 100644 (file)
@@ -15,4 +15,5 @@ GENPART_SITE          = http://www.pengutronix.de/software/genpart/download
 # So, until the authors have clarified the licensing terms:
 GENPART_LICENSE       = Unknown (clarification has been asked to the authors)
 
+$(eval $(autotools-package))
 $(eval $(host-autotools-package))