Fixup ldconfig symlink
authorEric Andersen <andersen@codepoet.org>
Wed, 12 Feb 2003 12:43:44 +0000 (12:43 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 12 Feb 2003 12:43:44 +0000 (12:43 -0000)
make/uclibc_toolchain.mk
make/uclibc_toolchain_2_95.mk

index 74e780260b87f0d92d24966b3639296bab85983a..69e4637a6ed6468bfdb313a5dc87617e27c38d18 100644 (file)
@@ -343,7 +343,7 @@ $(TARGET_DIR)/lib/libc.so.0: $(STAGING_DIR)/lib/libc.a
 
 $(TARGET_DIR)/usr/bin/ldd: $(TARGET_DIR)/lib/libc.so.0
        $(MAKE) -C $(UCLIBC_DIR) PREFIX=$(TARGET_DIR) install_target_utils
-       (cd $(TARGET_DIR)/sbin; ln -s /bin/true ldconfig) 
+       (cd $(TARGET_DIR)/sbin; ln -sf /bin/true ldconfig) 
 
 UCLIBC_TARGETS=$(TARGET_DIR)/lib/libc.so.0 $(TARGET_DIR)/usr/bin/ldd
 endif
index 0c08e097c4c25ae2aca6c7cb49c2719abec8daae..a5170353c106332b5783157fc6eba031207a72fe 100644 (file)
@@ -365,7 +365,7 @@ $(TARGET_DIR)/lib/libc.so.0: $(STAGING_DIR)/lib/libc.a
 
 $(TARGET_DIR)/usr/bin/ldd: $(TARGET_DIR)/lib/libc.so.0
        $(MAKE) -C $(UCLIBC_DIR) PREFIX=$(TARGET_DIR) install_target_utils
-       (cd $(TARGET_DIR)/sbin; ln -s /bin/true ldconfig) 
+       (cd $(TARGET_DIR)/sbin; ln -sf /bin/true ldconfig) 
 
 UCLIBC_TARGETS=$(TARGET_DIR)/lib/libc.so.0 $(TARGET_DIR)/usr/bin/ldd
 endif