package/libglib2: bump version to 2.64.1
authorAdam Duskett <Aduskett@gmail.com>
Thu, 12 Mar 2020 19:41:43 +0000 (12:41 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 12 Mar 2020 20:41:46 +0000 (21:41 +0100)
Other changes:
  - Change -Dlibmount from a bool to a feature.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libglib2/0001-fix-compile-time-atomic-detection.patch
package/libglib2/0002-allow-explicit-disabling-of-tests.patch
package/libglib2/0003-remove-cpp-requirement.patch
package/libglib2/0004-Add-Wno-format-nonliteral-to-compiler-arguments.patch
package/libglib2/libglib2.hash
package/libglib2/libglib2.mk

index a471275243b953e173d7a5fd1caac824a3dad17a..9d2381bb35115eef579ad48fc03ad2344e227705 100644 (file)
@@ -18,7 +18,7 @@ diff --git a/glib/gthread-posix.c b/glib/gthread-posix.c
 index 71a6b7b..d09d029 100644
 --- a/glib/gthread-posix.c
 +++ b/glib/gthread-posix.c
-@@ -68,7 +68,7 @@
+@@ -73,7 +73,7 @@
  #endif
  
  /* clang defines __ATOMIC_SEQ_CST but doesn't support the GCC extension */
index d6c62499c34b33d513a825d8b17ec7704c49cd7c..c865c04e0376630529c6cc0662f548e144bd8b3b 100644 (file)
@@ -23,7 +23,7 @@ diff --git a/meson.build b/meson.build
 index 99806d0..3206603 100644
 --- a/meson.build
 +++ b/meson.build
-@@ -77,7 +77,7 @@ installed_tests_template = files('template.test.in')
+@@ -84,7 +84,7 @@ installed_tests_template = files('template.test.in')
  installed_tests_template_tap = files('template-tap.test.in')
  
  # Don’t build the tests unless we can run them (either natively, in an exe wrapper, or by installing them for later use)
index d28f8ab81c48e426f9f8341b9b477d96122cef19..e6632cb062a38edb8847eaeb274bb48f073671c3 100644 (file)
@@ -35,7 +35,7 @@ index 4bbf4c2..ac59f4e 100644
 @@ -1,4 +1,4 @@
 -project('glib', 'c', 'cpp',
 +project('glib', 'c',
-   version : '2.62.4',
+   version : '2.64.1',
    # NOTE: We keep this pinned at 0.49 because that's what Debian 10 ships
    meson_version : '>= 0.49.2',
 @@ -10,7 +10,6 @@ project('glib', 'c', 'cpp',
@@ -46,7 +46,7 @@ index 4bbf4c2..ac59f4e 100644
  
  cc_can_run = not meson.is_cross_build() or meson.has_exe_wrapper()
  
-@@ -1484,20 +1483,6 @@ if g_have_iso_c_varargs
+@@ -1548,20 +1547,6 @@ if g_have_iso_c_varargs
  #endif''')
  endif
  
@@ -67,7 +67,7 @@ index 4bbf4c2..ac59f4e 100644
  g_have_gnuc_varargs = cc.compiles('''
    void some_func (void) {
      int a(int p1, int p2, int p3);
-@@ -2095,7 +2080,6 @@ subdir('gobject')
+@@ -2167,7 +2152,6 @@ subdir('gobject')
  subdir('gthread')
  subdir('gmodule')
  subdir('gio')
@@ -79,7 +79,7 @@ diff --git a/tests/meson.build b/tests/meson.build
 index e4ea226..7fd974c 100644
 --- a/tests/meson.build
 +++ b/tests/meson.build
-@@ -56,11 +56,6 @@ tests = {
+@@ -55,11 +55,6 @@ tests = {
      'source': 'module-test.c',
      'c_args': ['-DMODULE_TYPE="plugin"'],
    },
index b76dd76f2f1ce7d5943a9732b900e1c6d5655b00..f792ceba3f2b086c1b747d26aef81375c44cd63a 100644 (file)
@@ -15,7 +15,7 @@ diff --git a/meson.build b/meson.build
 index 3c615b7..7cae4e8 100644
 --- a/meson.build
 +++ b/meson.build
-@@ -366,6 +366,7 @@ if cc.get_id() == 'gcc' or cc.get_id() == 'clang'
+@@ -372,6 +372,7 @@ if cc.get_id() == 'gcc' or cc.get_id() == 'clang'
      '-Wno-cast-function-type',
 +    '-Wno-format-nonliteral',
      # Due to function casts through (void*) we cannot support -Wpedantic:
index e3478f06bb896e88f9be49e2d37e9168e0eadf75..345a01ba37cc6cc8050aa8807e1c9ac2a946e299 100644 (file)
@@ -1,4 +1,4 @@
-# https://download.gnome.org/sources/glib/2.62/glib-2.62.4.sha256sum
-sha256  4c84030d77fa9712135dfa8036ad663925655ae95b1d19399b6200e869925bbc  glib-2.62.4.tar.xz
+# https://download.gnome.org/sources/glib/2.64/glib-2.64.1.sha256sum
+sha256  17967603bcb44b6dbaac47988d80c29a3d28519210b28157c2bd10997595bbc7  glib-2.64.1.tar.xz
 # License files, locally calculated
 sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING
index f00818f69c681dd370736543d86dd55c78f92e3b..1b9eef7147151ba20b5dcc6cd40ff005b47a6c12 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-LIBGLIB2_VERSION_MAJOR = 2.62
-LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).4
+LIBGLIB2_VERSION_MAJOR = 2.64
+LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).1
 LIBGLIB2_SOURCE = glib-$(LIBGLIB2_VERSION).tar.xz
 LIBGLIB2_SITE = http://ftp.gnome.org/pub/gnome/sources/glib/$(LIBGLIB2_VERSION_MAJOR)
 LIBGLIB2_LICENSE = LGPL-2.1+
@@ -80,10 +80,10 @@ endef
 endif
 
 ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBMOUNT),y)
-LIBGLIB2_CONF_OPTS += -Dlibmount=true
+LIBGLIB2_CONF_OPTS += -Dlibmount=enabled
 LIBGLIB2_DEPENDENCIES += util-linux
 else
-LIBGLIB2_CONF_OPTS += -Dlibmount=false
+LIBGLIB2_CONF_OPTS += -Dlibmount=disabled
 endif
 
 # Purge useless binaries from target