dbus: fix xml dependency and stop continous rebuilds
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 30 Jan 2009 13:54:47 +0000 (13:54 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 30 Jan 2009 13:54:47 +0000 (13:54 -0000)
package/dbus/dbus.mk

index c98827ba33b49a273beb3bd5013eb9b004b7a3e0..c8ee4010562c0c99388cd01e4cbde39b17205cad 100644 (file)
@@ -13,19 +13,12 @@ DBUS_TARGET_BINARY:=usr/bin/dbus-daemon
 
 ifeq ($(BR2_DBUS_EXPAT),y)
 DBUS_XML:=expat
-# depend on the exact library file instead of expat so dbus isn't always
-# considered out-of-date
-DBUS_XML_DEP_LIB:=$(STAGING_DIR)/usr/lib/libexpat.so.1
+DBUS_XML_DEP:=expat
 else
 DBUS_XML:=libxml
-# Makefile.autotools.in unfortunately has broken dependency handling,
-# so we cannot do the same for libxml2
-DBUS_XML_DEP_LIB:=$(LIBXML2_HOOK_POST_INSTALL)
-#libxml2-install-staging
+DBUS_XML_DEP:=libxml2
 endif
 
-DBUS_XML_DEP:=$(DBUS_XML_DEP_LIB)
-
 $(DL_DIR)/$(DBUS_SOURCE):
        $(call DOWNLOAD,$(DBUS_SITE),$(DBUS_SOURCE))
 
@@ -35,7 +28,7 @@ $(DBUS_DIR)/.unpacked: $(DL_DIR)/$(DBUS_SOURCE)
        $(DBUS_CAT) $(DL_DIR)/$(DBUS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
        touch $@
 
-$(DBUS_DIR)/.configured: $(DBUS_DIR)/.unpacked $(DBUS_XML_DEP)
+$(DBUS_DIR)/.configured: $(DBUS_DIR)/.unpacked
        (cd $(DBUS_DIR); rm -rf config.cache; \
                $(TARGET_CONFIGURE_OPTS) \
                $(TARGET_CONFIGURE_ARGS) \
@@ -93,7 +86,7 @@ ifneq ($(BR2_HAVE_MANPAGES),y)
        rm -rf $(TARGET_DIR)/usr/share/man
 endif
 
-dbus: uclibc pkgconfig $(TARGET_DIR)/$(DBUS_TARGET_BINARY)
+dbus: uclibc pkgconfig $(DBUS_XML_DEP) $(TARGET_DIR)/$(DBUS_TARGET_BINARY)
 
 dbus-clean:
        rm -f $(TARGET_DIR)/etc/dbus-1/session.conf