xbmc: Add comment for host-sdl_images dependency
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Thu, 27 Mar 2014 22:40:46 +0000 (23:40 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 27 Mar 2014 22:48:56 +0000 (23:48 +0100)
A few people have already asked why XBMC depends on host-sdl_image and
host-sdl.

Since this is not obvious, this patch add a comments explaining why it's
needed.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/xbmc/xbmc.mk

index a43b41dbb3b633bd799f6016f8aa7bd093599372..6dbbb7dba79998673b62a1b8a54baef04108d3aa 100644 (file)
@@ -8,6 +8,10 @@ XBMC_VERSION = 12.3-Frodo
 XBMC_SITE = $(call github,xbmc,xbmc,$(XBMC_VERSION))
 XBMC_LICENSE = GPLv2
 XBMC_LICENSE_FILES = LICENSE.GPL
+# XBMC needs host-sdl_image (and therefore host-sdl) for a host tools it builds
+# called TexturePacker. It is responsible to take all the images used in the
+# GUI and pack them in a blob.
+# http://wiki.xbmc.org/index.php?title=TexturePacker
 XBMC_DEPENDENCIES = host-gperf host-lzo host-sdl_image host-swig
 XBMC_DEPENDENCIES += boost bzip2 expat flac fontconfig freetype jasper jpeg \
        libass libcdio libcurl libfribidi libgcrypt libmad libmodplug libmpeg2 \