package/imagemagick: add optional support for webp
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 Feb 2016 17:57:30 +0000 (18:57 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 20:30:57 +0000 (21:30 +0100)
When webp was compiled before, imagemagick will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/stream | grep NEEDED
 0x0000000000000001 (NEEDED)             Shared library: [libMagickCore-6.Q16.so.2]
 0x0000000000000001 (NEEDED)             Shared library: [libMagickWand-6.Q16.so.2]
 0x0000000000000001 (NEEDED)             Shared library: [libjpeg.so.8]
 0x0000000000000001 (NEEDED)             Shared library: [libwebp.so.5]
[...]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/imagemagick/imagemagick.mk

index 8fc95323d1836cdd580ae8f30230c8099abd5763..639b0e853cb463122d170c9daaddf81d67965a33 100644 (file)
@@ -105,6 +105,13 @@ else
 IMAGEMAGICK_CONF_OPTS += --without-fftw
 endif
 
+ifeq ($(BR2_PACKAGE_WEBP),y)
+IMAGEMAGICK_CONF_OPTS += --with-webp
+IMAGEMAGICK_DEPENDENCIES += webp
+else
+IMAGEMAGICK_CONF_OPTS += --without-webp
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 IMAGEMAGICK_CONF_OPTS += --with-zlib
 IMAGEMAGICK_DEPENDENCIES += zlib